Page MenuHomePhabricator

Special:Contributions - update `IP address or username` label type
Closed, ResolvedPublic

Description

Prior to T220447: Split out or remove Special:Contributions/newbies functionality, Special:Contributions could be used to view either the contributions of a single user/IP or those of "newbies". A radio label was used to select the functionality desired. Now that newbies is no longer an option, the label should be converted from Xml::radioLabel to just Xml::label. Since radioLabel is just a wrapper for a radio element followed by a label, the change is fairly simple.

Details

Event Timeline

Restricted Application added a project: User-DannyS712. · View Herald TranscriptSep 5 2019, 11:31 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 534708 had a related patch set uploaded (by DannyS712; owner: DannyS712):
[mediawiki/core@master] Special:Contributions - use label instead of radioLabel for username

https://gerrit.wikimedia.org/r/534708

Xaosflux added a subscriber: Xaosflux.

Change 534708 merged by jenkins-bot:
[mediawiki/core@master] Special:Contributions - use label instead of radioLabel for username

https://gerrit.wikimedia.org/r/534708

DannyS712 closed this task as Resolved.Sep 9 2019, 7:07 PM

Confirmed on the beta cluster