Page MenuHomePhabricator

Lift IP cap for edit-a-thon at Bard College Nov. 11, 2019
Closed, ResolvedPublic

Description

We are hosting two edit-a-thons as the culmination of academic coursework in two classes at Bard College the week of November 11th. Students are registering in advance to practice in sandboxes before the edit-a-thon. The influx of new user registrations this week has caused our IP to be blocked. Could you temporarily lift the IP cap on these addresses? Ideally, we could lift that cap from now until November 15 at 12:00pm Eastern when the last edit-a-thon is over. If that is too long, lifting the cap even for a few days would be helpful.

  • 173.46.96.0 255.255.224.0
  • 192.246.224.0 255.255.248.0
  • 192.246.233.0 255.255.255.0
  • 192.246.234.0 255.255.255.0
  • 192.246.235.0 255.255.255.0
  • 192.76.239.0 255.255.255.0
  • 192.83.253.0 255.255.255.0

Thanks in advance for your help.

Details

Related Gerrit Patches:
wikimedia/fundraising/crm : masterAdd some indexes that are missing.
operations/mediawiki-config : masterAdd throttle rule for bard college editathon

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptWed, Oct 30, 8:33 PM
MarcoAurelio renamed this task from Wikimedia-Site-requests to Lift IP cap for edit-a-thon at Bard College Nov. 11, 2019.Wed, Oct 30, 8:51 PM
MarcoAurelio updated the task description. (Show Details)

@EditingOedipa: Thanks for creating this ticket. Please provide all required information, including number of users and which website this is about.

@Aklapper thanks for the prompt and apologies for the incomplete information. The total number of new registrations for this project will not exceed 40, including those that have successfully registered this week. I can't provided a more specific number for new registrations as, at the moment, we have a mix of students who successfully registered and those that are blocked. I would estimate the blocked number to be about about 15 students. I don't have a registered class project page, but I am the coordinator for the project and we are editing articles on local towns and cities, and African American cultural producers. Let me know if I can provide any more specifics and thanks again for your help.

Also attaching screenshots of errors, in case that provides additional context...

Those two screenshots are for IPs falling into 23.227.128.0/19, which is not mentioned in this task description. This range was blocked by @SQL, as Colocationwebhost. What that means is described in the block reasoning.

Put shortly, this range is owned by a hosting provider 24 SHELLS (https://www.24shells.net/). Because those IP addresses can easily be abused to bypass IP-based restrictions, they have been blocked.

The IP addresses listed in the task description seems to be owned by Bard College. However, your computers seems to use a different IP address. Please check with your IT departament about possible VPN or proxy enabled that would use IP address from 23.227.128.0/19 range, and have this proxying disabled (at least for Wikimedia network). Then, we would gladly add a throttle exemption to make your events run more smoothly.

Urbanecm changed the task status from Open to Stalled.Thu, Oct 31, 3:46 PM
Urbanecm triaged this task as Low priority.

Stalling until the block problem is resolved.

SQL added a comment.Sat, Nov 2, 1:04 AM

Hm. It's plausible, albeit strange that the college routes it's outbound traffic via 24SHELLS for some reason. If it gets in the way of the edit-a-thon, and there's no way around it, I'm fine with dropping the block for a week or two - either by me, or any other admin.

Thanks @SQL and @Urbanecm for your work on this ticket. I've confirmed that the screenshots attached, and hence the 23... IP, is indeed from a VPN installed on the student's computer. Bard College does not route outgoing traffic this way.

I'm unsure how many of the students who have been blocked have VPNs installed or if they're hitting the registration throttle. Is it possible to lift the throttle just for the Bard addresses?

173.46.96.0 255.255.224.0
192.246.224.0 255.255.248.0
192.246.233.0 255.255.255.0
192.246.234.0 255.255.255.0
192.246.235.0 255.255.255.0
192.76.239.0 255.255.255.0
192.83.253.0 255.255.255.0

Is it best for students with VPNs installed to simply register and edit from campus computers if they don't know how to turn it off? The student whose screenshots I used, Meledit2089 tried turning her VPN off and filed an unblock appeal, but as of Friday, her account was still blocked.

Thank you again for your help on this.

Change 548453 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Add throttle rule for bard college editathon

https://gerrit.wikimedia.org/r/548453

Urbanecm changed the task status from Stalled to Open.Mon, Nov 4, 7:14 PM

Change 548453 merged by jenkins-bot:
[operations/mediawiki-config@master] Add throttle rule for bard college editathon

https://gerrit.wikimedia.org/r/548453

Mentioned in SAL (#wikimedia-operations) [2019-11-04T19:16:59Z] <urbanecm@deploy1001> Synchronized wmf-config/throttle.php: SWAT: 6a4b966: Add throttle rule for bard college editathon (T236955) (duration: 00m 54s)

Urbanecm closed this task as Resolved.Mon, Nov 4, 7:18 PM
Urbanecm claimed this task.
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptMon, Nov 4, 7:18 PM
SQL added a comment.Mon, Nov 4, 8:07 PM

The student whose screenshots I used, Meledit2089 tried turning her VPN off and filed an unblock appeal, but as of Friday, her account was still blocked.
Thank you again for your help on this.

Her account shouldn't be blocked - the underlying IP likely is however.

One thing that happens with these rangeblocks is that a cookie is set, which activates the autoblock the next time that the user edits, no matter what IP they edit from.

If a user has attempted to edit via VPN, and gotten a block message - they will need to clear cookies. There are some instructions for how to do this in most browsers here: Wikipedia:Bypass_your_cache#Cache_clearing_and_disabling.

Change 550783 had a related patch set uploaded (by Ejegg; owner: Eileen):
[wikimedia/fundraising/crm@master] Add some indexes that are missing.

https://gerrit.wikimedia.org/r/550783

Change 550783 merged by jenkins-bot:
[wikimedia/fundraising/crm@master] Add some indexes that are missing.

https://gerrit.wikimedia.org/r/550783