Page MenuHomePhabricator

Users on dewiki have been automatically switched to use the enhanced recent changes and watchlist
Open, Needs TriagePublic

Description

On 2019-11-27 (for me around noon), some users on dewiki have been automatically switched to use the enhanced version of the recent changes and the watchlist (the page grouped entry view, not the new edit filters). They had to re-deactivate the feature called "Group changes by page in recent changes and watchlist" on Special:Preferences.

Thread: https://de.wikipedia.org/wiki/Wikipedia:Fragen_zur_Wikipedia#Beobachtungsliste

Was this part of a coordinated action or kind of accidental?

Event Timeline

hgzh created this task.Nov 27 2019, 11:17 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptNov 27 2019, 11:17 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Aklapper updated the task description. (Show Details)Nov 27 2019, 11:46 PM

Please fix this problem.

@Toni_Mueller: See the task description for a workaround: "re-deactivate the feature called "Group changes by page in recent changes and watchlist" on Special:Preferences." Did that not work, and/or did you have to do this several times?

This could be T202916: Stop changing my "Group results by page" prefs based on a URL that I've clicked on.
Scenario: there is a public convenience link which contains enhanced=1.

hgzh added a comment.Mon, Jan 13, 1:11 PM

@matej_suchanek @Toni_Mueller that could be the reason. I found a link on dewiki's administartor's noticeboard containing enhanced=1 added on the day when the first complaints popped up. An user also already seemed to be on the right track.

I removed another enhanced=1 link from a category service template, all other occurences I found were older.

This could be closed as duplicate of T202916 IMO.