Page MenuHomePhabricator

HTTP 404 for several images in page namespace on different wikisource projects
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  • Example in pa.wikisource

https://pa.wikisource.org/wiki/ਪੰਨਾ:ਅਰਸ਼ੀ_ਝਲਕਾਂ.pdf/141

The page above don't have a picture but the source file has an image
Link for the source file(https://pa.wikisource.org/w/index.php?title=ਤਸਵੀਰ:ਅਰਸ਼ੀ_ਝਲਕਾਂ.pdf&page=148)

Expected Results: The page must show a picture on the right side of the page.

  • Example in ta.wikisource [From T242329]

https://ta.wikisource.org/s/1l97

None of the pages liked in this index page is showing the image of the book in the page namespace. The same was appearing previously.

Pages unrelated to this book is appearing as usual. Check the file in commons. The pages are visible in commons.

Details

Related Gerrit Patches:
mediawiki/extensions/PdfHandler : masterSanitize $param['width'] to avoid float number

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 9 2020, 5:52 AM

Hi Rupika and Satpal,

There is a ticket about the rendering issue of this file (
https://pa.wikisource.org/wiki/ਤਸਵੀਰ:ਅਰਸ਼ੀ_ਝਲਕਾਂ.pdf). I have fixed the
file ( attached). Could you please update/override the file? I can't do
that because it is a local upload, and I am not an admin.

Regards,
Jayanta Da

Dear Jayanta Nath,

I have updated this file and the issue has been resolved. @HardarshanGamer
<Hardarshanbenipal.hb@gmail.com> Please have a look.

Thank you.

*Regards*

*Satpal*

Aklapper closed this task as Resolved.Jan 9 2020, 10:38 AM

The images are missing from majority of the books in the Punjabi
Wikisource. Seems like a technical issue.

The images are missing from majority of the books in the Punjabi
Wikisource. Seems like a technical issue.

Hardarshan2207 reopened this task as Open.Jan 10 2020, 2:52 PM
Aklapper renamed this task from Image not visible to HTTP 404 for several images in page namespace on pa.wikisource.Jan 10 2020, 4:08 PM
Aklapper added a project: SRE-swift-storage.
Bodhisattwa renamed this task from HTTP 404 for several images in page namespace on pa.wikisource to HTTP 404 for several images in page namespace on different wikisource projects.Jan 11 2020, 6:19 AM
Bodhisattwa reopened this task as Open.
Bodhisattwa updated the task description. (Show Details)
Bodhisattwa added a subscriber: Balajijagadesh.
Bodhisattwa added a subscriber: Bodhisattwa.

merged T242329 here as this seems to be an issue of other Wikisource projects also, for example, the same issue has been reported by Gujarati community in telegram chat.

Change 564115 had a related patch set uploaded (by Jayprakash12345; owner: Jayprakash12345):
[mediawiki/extensions/PdfHandler@master] Sanitize $param['width'] to avoid float number

https://gerrit.wikimedia.org/r/564115

Thanks to @Hrishikes Ji for informing us in Indic-Telegram Group that images is broken due to fraction in page width.

  1. https://pa.wikisource.org/wiki/ਪੰਨਾ:ਰੂਪ_ਲੇਖਾ.pdf/1 --> page1-593.75px-ਰੂਪ_ਲੇਖਾ.pdf.jpg
  2. https://gu.wikisource.org/wiki/પૃષ્ઠ:Vyajno_Varas.pdf/૨૩૦ --> page230-787.5px-Vyajno_Varas.pdf.jpg

I have write the a UserScript to fix fractions as Hot-Fix and Testing. See Jayprakash12345/common.js So after enabling it

So wikisources can use this script until we have not fixed it in MediaWiki-extensions-PdfHandler.

Jayprakash12345 triaged this task as High priority.Jan 13 2020, 8:42 PM

@Sushant_savla Ji, Every page is redenering with script. Do you wait to load the page? Please wait because userscripts only runs after the DOM is read.

Jayprakash12345 added a comment.EditedJan 15 2020, 9:07 PM

@Sushant_savla The problem is Here with your Common.js. You are using Template in UserScript. which is breaking the UserScript. So remove the Template from your common.js

@Jayprakash12345 thank you for your help. Now i can see the images

Pikne added a subscriber: Pikne.Jan 29 2020, 8:01 AM

This should be fixed now. See T242517.

Aklapper closed this task as Resolved.Feb 8 2020, 1:36 PM

Closing per last comment. Please set the status of this task back to "Open" via the Add Action...Change Status dropdown if this still happens. Thanks!

Change 564115 abandoned by Jayprakash12345:
Sanitize $param['width'] to avoid float number

https://gerrit.wikimedia.org/r/564115