Page MenuHomePhabricator

Unable to remove P727 - The save has failed.
Closed, ResolvedPublicBUG REPORT

Description

Steps to reproduce:
Either manually or via quickstatements, attempt to remove the use of P727 (Europeana ID) from an item in the list below

Expected result:
Can remove

Actual result:
Cannot remove Could not remove due to an error. The save has failed. (wikibase-api-failed-save)

Affected items:

Q17298489
Q17388972
Q17435266
Q17437647
Q17442217
Q17448706
Q17458771
Q17463635
Q17464689
Q17590585
Q17608186
Q17374105
Q17415430
Q17455285
Q17455585
Q17458212
Q17461736
Q17464171
Q17594350
Q17597403
Q17597420
Q17603575
Q17195362
Q17203492
Q17342913
Q17341413
Q17373633
Q17437085
Q17449463
Q17460282
Q17463318
Q17596716
Q17597404
Q17439115
Q17445165
Q17456643
Q17456645
Q17457555
Q17458773
Q17590141
Q17590405
Q17599510
Q17611546
Q17459721
Q17463636
Q17469448
Q17597327
Q17598777
Q17599921
Q17605841
Q17437593
Q17437597
Q17463125
Q17596790
Q17604712
Q17608201
Q17345311
Q17436513
Q17457568
Q17459720
Q17460283
Q17463353
Q17596117
Q17610135
Q17400195
Q17437092
Q17447811
Q17465256
Q17590410
Q17596116

See quickstatements attempt: https://tools.wmflabs.org/quickstatements/#/batch/27217
Not all items were attempted manually, but all failed on quickstatements

Event Timeline

Restricted Application added projects: Wikidata, User-DannyS712. · View Herald TranscriptMar 25 2020, 2:17 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
DannyS712 moved this task from Unsorted to Reports on the User-DannyS712 board.Mar 25 2020, 2:17 AM
DannyS712 updated the task description. (Show Details)
DannyS712 changed the subtype of this task from "Task" to "Bug Report".

I tried it with Q17437647 in the API sandbox and the error response includes some more information:

{
    "errors": [
        {
            "code": "failed-save",
            "text": "The save has failed.",
            "module": "wbremoveclaims"
        },
        {
            "code": "wikibase-validator-sitelink-conflict",
            "text": "The link [https://commons.wikimedia.org/wiki/Category:Protestantse_Kerk_(Twisk) commonswiki:Category:Protestantse Kerk (Twisk)] is already used by Item [[Q17437646|Q17437646]]. You may remove it from [[Q17437646|Q17437646]] if it does not belong there or merge the Items if they are about the exact same topic.",
            "module": "wbremoveclaims"
        },
        {
            "code": "failed-save",
            "text": "The save has failed.",
            "data": {
                "messages": [
                    {
                        "name": "wikibase-api-failed-save",
                        "parameters": [],
                        "html": "The save has failed."
                    },
                    {
                        "name": "wikibase-validator-sitelink-conflict",
                        "parameters": [
                            "[https://commons.wikimedia.org/wiki/Category:Protestantse_Kerk_(Twisk) commonswiki:Category:Protestantse Kerk (Twisk)]",
                            "[[Q17437646|Q17437646]]"
                        ],
                        "html": "Site link <a class=\"external text\" href=\"https://commons.wikimedia.org/wiki/Category:Protestantse_Kerk_(Twisk)\">commonswiki:Category:Protestantse Kerk (Twisk)</a> is already used by item <a href=\"/wiki/Q17437646\" title=\"Q17437646\">Q17437646</a>. Perhaps the items should be <a href=\"/wiki/Special:MyLanguage/Help:Merge\" title=\"Special:MyLanguage/Help:Merge\">merged</a> and one of them <a href=\"/wiki/Special:MyLanguage/Wikidata:Deletion_policy\" title=\"Special:MyLanguage/Wikidata:Deletion policy\">deleted</a>? Request deletion of one of the items at <a href=\"/wiki/Wikidata:Requests_for_deletions\" title=\"Wikidata:Requests for deletions\">d:Wikidata:Requests for deletions</a>, or ask at <a href=\"/wiki/Wikidata:Interwiki_conflicts\" title=\"Wikidata:Interwiki conflicts\">d:Wikidata:Interwiki conflicts</a> if you believe that they should not be merged."
                    }
                ]
            },
            "module": "wbremoveclaims"
        }
    ],
    "docref": "See https://www.wikidata.org/w/api.php for API usage. Subscribe to the mediawiki-api-announce mailing list at &lt;https://lists.wikimedia.org/mailman/listinfo/mediawiki-api-announce&gt; for notice of API deprecations and breaking changes.",
    "servedby": "mw1363"
}

The link commonswiki:Category:Protestantse Kerk (Twisk) is already used by Item Q17437646. You may remove it from Q17437646 if it does not belong there or merge the Items if they are about the exact same topic.

Site link commonswiki:Category:Protestantse Kerk (Twisk) is already used by item Q17437646. Perhaps the items should be merged and one of them deleted? Request deletion of one of the items at d:Wikidata:Requests for deletions, or ask at d:Wikidata:Interwiki conflicts if you believe that they should not be merged.

Other edits also seem to fail (I tried adding an English description), so I don’t think this is related to P​727.

Would it be possible to allow other edits to go through even if the sitelink conflicts?

The inconsistent database strikes again! T50260 was closed as a duplicate (pun intended) and links to T44325 . The items show up on https://www.wikidata.org/wiki/Wikidata:True_duplicates and are not duplicates and should not be merged.

https://w.wiki/LST indicates that 70 of these are Rijksmonumenten. I'll work my way through them. Let's see what's left after that.

Multichill closed this task as Resolved.Mar 29 2020, 8:44 PM
Multichill claimed this task.
Multichill added a subscriber: hoo.

I cleaned up all these cases and asked @hoo to update https://www.wikidata.org/wiki/Wikidata:True_duplicates . Judging from the last edit times of these items this is an old issue that just hasn't been cleaned up yet. Marking this one as resolved because I think we have nothing left to do here.