Page MenuHomePhabricator

Pywikibot on PAWS is not getting updates to latest stable
Closed, ResolvedPublic

Description

The Pywikibot installation on PAWS is out of date and is in need of and update to make sure users can take advantage of all the bug fixes and features.

The installation seems to be pinned very specifically to the following so there might be more to it then simply bumping the version.
git+https://gerrit.wikimedia.org/r/pywikibot/core.git@71e36c1574454d9438deaac08754ee4484dc4797#egg=pywikibot

Event Timeline

Abbe98 created this task.May 9 2020, 12:10 PM
Multichill added a subscriber: Xqt.
Restricted Application added a subscriber: pywikibot-bugs-list. · View Herald TranscriptMay 9 2020, 12:13 PM
Xqt added a comment.EditedMay 9 2020, 1:17 PM

See T217908 and I propose to decline this request. The stable tag should be used by default. The master branch is for development only.

See also https://www.mediawiki.org/wiki/Manual:Pywikibot/Version_table

By the way: The last stable release way deployed yesterday.

Abbe98 added a comment.May 9 2020, 1:23 PM

@Xqt when pwb is installed with "pip install pywikibot" I get a more recent version. Is the PAWS pwb actually up to date? To me it looks like the docker file were initiated with the stable branch but might have gotten out of date.

See T217908 and I propose to decline this request. The stable tag should be used by default. The master branch is for development only.

The problem is it runs the stable from last year.

Dvorapa added a subscriber: Dvorapa.EditedMay 9 2020, 1:26 PM

Perhaps it just needs to update stable tag? (git fetch --tags)

https://github.com/toolforge/paws/blob/9f524591cf7cc72ff9e10212f07023ee28618347/paws/values.yaml#L133 This needs fixing

Update: Oh, git pull --tags then. And maybe also add --force, it depends on git version though if force is necessary.

Salgo60 added a subscriber: Salgo60.May 9 2020, 1:29 PM

Mentioned in SAL (#wikimedia-cloud) [2020-05-09T13:31:51Z] <zhuyifei1999_> root@tools-paws-master-01:/home/chicocvenancio/paws# git pull && ./build.py deploy prod T252290

zhuyifei1999 closed this task as Resolved.EditedMay 9 2020, 1:38 PM
zhuyifei1999 claimed this task.

PR, https://github.com/toolforge/paws/pull/47 self-merged & deployed.

I tested and seems to work, resolving. Reopen if not.

zhuyifei1999 renamed this task from Update Pywikibot to the most recent version to Pywikibot on PAWS is not getting updates to latest stable.May 9 2020, 1:42 PM
Abbe98 added a comment.May 9 2020, 1:56 PM

Confirming it works and resolves my particular issue. Thank you @zhuyifei1999!