Page MenuHomePhabricator

InternetArchiveBot duplicate original link on Arabic Wikipedia
Closed, ResolvedPublic

Description

Hello, per this comment, we found that IABot put the original link again.

Example:
This bot edit. If u search about "https://books.google.com/books?id=vzZ71Eh5QvMC" you'll found 2 links before (1 original + 1 archived), but after IABot edit, it's being 3 (2 original + 1 archived).

Event Timeline

I have investigated the cause, and it is because the archive URL snapshot is not identical to the original. If you notice that the original link points to a page number within the query, the archive URL does not. To the bot that means a different output is produced. This can be resolved by either removing the page from the original URL, or adding the page to the archive URL.

Cyberpower678 closed this task as Resolved.Fri, Aug 7, 5:18 PM
Cyberpower678 claimed this task.

I have made some changes to make this a little more intelligent in v2.0.3

Thanks @Cyberpower678, so when we can try it again on arwiki?

v2.0.3 will go live by the end of tomorrow.