Page MenuHomePhabricator

Class 'CentralAuthUser' not found
Closed, ResolvedPublic

Description

Error

MediaWiki version: 1.36.0-wmf.1

message
Class 'CentralAuthUser' not found

Impact

A few of these just happened after train reached group1. Not enough, I think, to be a blocker, but they do sound worrying. I would appreciate a quick triage, and am marking this Unbreak Now because of that. Just in case it's actually bad enough that we need to roll back.

Notes

Details

Request ID
780dd86e-4ba7-4183-9e89-d9362bc45e08
Request URL
https://internal.wikimedia.org/w/index.php?title=Special:UserLogin&returnto=Standar+operasional+penggunaan+ruang+kerja+dan+ruang+komunitas
Stack Trace
exception.trace
#0 /srv/mediawiki/php-1.36.0-wmf.1/includes/auth/AuthManager.php(360): ClosedWikiProvider->testForAuthentication(array)
#1 /srv/mediawiki/php-1.36.0-wmf.1/includes/specialpage/AuthManagerSpecialPage.php(372): MediaWiki\Auth\AuthManager->beginAuthentication(array, string)
#2 /srv/mediawiki/php-1.36.0-wmf.1/includes/specialpage/AuthManagerSpecialPage.php(502): AuthManagerSpecialPage->performAuthenticationStep(string, array)
#3 /srv/mediawiki/php-1.36.0-wmf.1/includes/htmlform/HTMLForm.php(707): AuthManagerSpecialPage->handleFormSubmit(array, VFormHTMLForm)
#4 /srv/mediawiki/php-1.36.0-wmf.1/includes/specialpage/AuthManagerSpecialPage.php(435): HTMLForm->trySubmit()
#5 /srv/mediawiki/php-1.36.0-wmf.1/includes/specialpage/LoginSignupSpecialPage.php(319): AuthManagerSpecialPage->trySubmit()
#6 /srv/mediawiki/php-1.36.0-wmf.1/includes/specialpage/SpecialPage.php(600): LoginSignupSpecialPage->execute(NULL)
#7 /srv/mediawiki/php-1.36.0-wmf.1/includes/specialpage/SpecialPageFactory.php(635): SpecialPage->run(NULL)
#8 /srv/mediawiki/php-1.36.0-wmf.1/includes/MediaWiki.php(307): MediaWiki\SpecialPage\SpecialPageFactory->executePath(Title, RequestContext)
#9 /srv/mediawiki/php-1.36.0-wmf.1/includes/MediaWiki.php(940): MediaWiki->performRequest()
#10 /srv/mediawiki/php-1.36.0-wmf.1/includes/MediaWiki.php(543): MediaWiki->main()
#11 /srv/mediawiki/php-1.36.0-wmf.1/index.php(53): MediaWiki->run()
#12 /srv/mediawiki/php-1.36.0-wmf.1/index.php(46): wfIndexMain()
#13 /srv/mediawiki/w/index.php(3): require(string)
#14 {main}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptThu, Jul 30, 11:09 AM
LarsWirzenius triaged this task as Unbreak Now! priority.Thu, Jul 30, 11:09 AM
Ammarpad added a subscriber: Ammarpad.EditedThu, Jul 30, 11:24 AM

Note that this will only happen in 'closed wikis' so probably the impact is limited. I think the root cause is that this happens because CentralAuth is not installed on some closed wikis but ClosedWikiProvider is being run on all of them

Urbanecm claimed this task.EditedThu, Jul 30, 11:33 AM
Urbanecm lowered the priority of this task from Unbreak Now! to High.
Urbanecm added a subscriber: Urbanecm.

This happens only in closed internal wikis, which are only in group1 and IIRC it should be only internalwiki. Declassyfing as a train blocker and going to upload a fix.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptThu, Jul 30, 11:33 AM

Change 617415 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] ClosedWikiProvider: Do not run when $wmgUseCentralAuth is false

https://gerrit.wikimedia.org/r/617415

Change 617415 merged by jenkins-bot:
[operations/mediawiki-config@master] ClosedWikiProvider: Do not run when $wmgUseCentralAuth is false

https://gerrit.wikimedia.org/r/617415

Mentioned in SAL (#wikimedia-operations) [2020-07-30T11:44:10Z] <urbanecm@deploy1001> Synchronized wmf-config/CommonSettings.php: fc5de151ee2c9cf5c64a7d13b2e65e39bb349296: ClosedWikiProvider: Do not run when $wmgUseCentralAuth is false (T259246) (duration: 01m 07s)

Urbanecm closed this task as Resolved.Thu, Jul 30, 11:46 AM

This should not happen anymore.