Page MenuHomePhabricator

CommunityConfiguration: Use a single term to describe a provider ID
Open, MediumPublic

Description

In CommunityConfiguration, client extensions register their providers like this:

"CommunityConfiguration": {
	"Providers": {
		"Mentorship": {
			"store": {
				"type": "wikipage",
				"args": [
					"MediaWiki:GrowthExperimentsMentorship.json"
				]
			},
			"validator": {
				"type": "jsonschema",
				"args": [
					"GrowthExperiments\\Config\\Schemas\\MentorshipSchema"
				]
			},
			"type": "mw-config"
		}
}

Since https://gerrit.wikimedia.org/r/c/mediawiki/extensions/CommunityConfiguration/+/1015078, we're referring to the Mentorship as the ID (key under which the provider is registered), and to whatever the communityconfiguration-LOWERCASE-ID-title (so in this case, communityconfiguration-mentorship-title) message resolves to as the name.

However, this refactor was not done in CommunityConfiguration's frontend and PROVIDER_NAME still refers to the title, not name. This causes confusion, as name means something else in BE and FE. To ensure CommunityConfiguration stays maintainable, this should be fixed.