Page MenuHomePhabricator

Special:ChangeEmail: When changing e-mail address x to the same x, the dialog with new address and password is shown but no mail is sent and process continues without any message
Closed, ResolvedPublic

Description

https://www.example.com/phase3/index.php?title=Special:ChangeEmail&returnto=Special%3APreferences

When you are on Special:Preferences and try to change a confirmed e-mail address x to the same value x (to trigger a confirmation mail, for test purposes or the like),

  • the mail address change screen is shown and you can enter of course the new address

Change account e-mail address

Complete this form to change your e-mail address. You will need to enter your password to confirm this change.
Username: WikiSysop
Current e-mail address: x
New e-mail address: x
Password: y

Problem

When you now press "Change e-mail", there is neither a confirmation message
"... has been sent" shown, nor an error message like "you tried to change your mail address to the previous value. Instead, the process flow goes back to Special:Preferences

Suggestions

i) show the user an info message (that no confirmation mail has been sent because the mail address was not sent) -- or --
ii) to go again trough the full confirmation procedure including sending an confirmation mail.

(pls. feel free to shorten the bug summary text)


Version: 1.21.x
Severity: minor

Details

Reference
bz36561
Related Gerrit Patches:

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 12:25 AM
bzimport set Reference to bz36561.
bzimport added a subscriber: Unknown Object (MLST).
Wikinaut created this task.May 5 2012, 8:52 PM

Created attachment 11172
browser tooltip and div are both validating e-mail

attachment 2012-10-09 ChangeEmail HTML5 screenshot.png ignored as obsolete

Comment on attachment 11172
browser tooltip and div are both validating e-mail

Ignore this, I intended this screenshot for a new bug.

Valerie.m.juarez wrote:

This issue still persists, and I will mention this in IRC. However, I will drop the priority.

Change 233106 had a related patch set uploaded (by Glaisher):
SpecialChangeEmail: error if old email was entered in new email field

https://gerrit.wikimedia.org/r/233106

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 22 2015, 12:32 PM

Change 233106 merged by jenkins-bot:
SpecialChangeEmail: error if old email was entered in new email field

https://gerrit.wikimedia.org/r/233106

Glaisher closed this task as Resolved.Sep 18 2015, 3:51 PM
Glaisher claimed this task.