Page MenuHomePhabricator

Japanese filenames do not appear in search results if file extension dropped
Closed, ResolvedPublic

Description

Author: sentberg

Description:
There seems to be a malfunction in using Japanese words to look for the files whose descriptions are partly or entirely written in Japanese language.

If the searching keyword contains the same letters in the same order as those of the targeted Japanese phrase (without either spaces or any words in other languages between the Japanese letters), the results will be satisfactory because every Japanese context essentially never has any space letter in itself.

However, when the keyword just matches to some parts of the whole phrase, or when it contains not the suffix but only the body of a Japanese file name (e.g. not "あいうえお.jpg" but only "あいうえお"), it will never be successful for the wanted files to appear in the results.

I would like you to make it possible for the searching engine to recognize some fragmentary letters which are the parts of the entire Japanese phrase, and to identify Japanese file names without its suffixes, so that it will be a great help to all the users who have to discover files in Japanese.

Thank you.


Version: unspecified
Severity: normal

Details

Reference
bz40612

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 12:49 AM
bzimport added projects: CirrusSearch, I18n.
bzimport set Reference to bz40612.
bzimport created this task.Sep 29 2012, 6:20 AM

Satoshi: By any chance, are you aware of an example for this problem that exists on commons.wikimedia.org?

demon removed a subscriber: demon.Aug 19 2015, 4:07 PM
Restricted Application added a project: Discovery. · View Herald TranscriptAug 19 2015, 4:07 PM
Deskana removed Manybubbles as the assignee of this task.Dec 30 2015, 9:28 PM
Deskana lowered the priority of this task from Normal to Low.

Unable to reproduce bug (works for me).

Searching for "しまねっこ" returns [[File:しまねっこ.jpg]]. Searching for "かぶらずし" returns [[File:かぶらずし.JPG]]. Note that neither of these images have their respective search keywords in the description, which indicates that the search is actually looking at the filename.

+1 for declining.

Deskana closed this task as Resolved.Jan 19 2016, 7:19 AM
Deskana claimed this task.

Unable to reproduce bug (works for me).

Thanks. Then I'll close this as resolved. :-)