Page MenuHomePhabricator

SF info page name parameter truncates values with apostrophes
Closed, ResolvedPublic

Description

Author: mitchell_neill

Description:
Hi.

I'm running SMW bundle 1.18, SF 2.5.1 on MW 1.19.3.

Continuing with the apostrophe testing. I'm using the SF one step process to create pages. The info page name parameter truncates values with apostrophes.

I have:

{{{info|add title=Add a Subsection|edit title=Editing Subsection|page name=<Subsection Admin[Parent]> - <Subsection Template[Subsection ID] }}}

If the Parent value contains an apostrophe, the page name is truncated and the - <Subsection Template[Subsection ID] part of the page name is missed off entirely.

Example. If the Parent is "What's New" and the Subsection ID is "Education". The resulting page is created as "What" instead of "What's New - Education.

Again, I'm sure this was fixed and working in an older version.

Any help appreciated. Apostrophes are very common, so not handling them is a real pain.

Thanks
Neill.


Version: unspecified
Severity: normal

Details

Reference
bz44105

Event Timeline

bzimport raised the priority of this task from to Needs Triage.
bzimport set Reference to bz44105.
bzimport created this task.Jan 18 2013, 2:35 PM

mitchell_neill wrote:

SMW is version 1.8 of course.

mitchell_neill wrote:

Fix to this of course would be to urlencode the value when passing it and then urldecoding it.

Aklapper removed Yaron_Koren as the assignee of this task.Sep 2 2015, 3:54 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 2 2015, 3:54 PM
Billghost claimed this task.Mar 8 2016, 2:07 PM

Hello
I've set up the SMW and SF on my local machine. When looking through I'm a bit overwhelmed with which file deals with the creation of pages so that I can spot that particular bug.

@Billghost - you don't need SMW installed for this one, by the way. Also, are you able to reproduce this bug?

@Yaron_Koren : No I wasn't able to reproduce it because I didn't know which page to create under the semantic forms namespace(tried create category page and create a form but couldn't reproduce it) in special pages on my localhost.

Alright. We should probably take this discussion "offline"... if you want to work on this bug, please email me at yaron57@gmail.com.

Change 277179 had a related patch set uploaded (by Billm):
Apply setting variable instead of direct warning value

https://gerrit.wikimedia.org/r/277179

Yaron_Koren removed Billghost as the assignee of this task.Mar 22 2016, 12:22 AM
Yaron_Koren added a subscriber: Billghost.

Change 277179 had a related patch set uploaded (by Billm):
Apply setting variable instead of direct warning value

https://gerrit.wikimedia.org/r/277179

Yaron_Koren closed this task as Resolved.Apr 14 2016, 3:24 PM

This appears to have been fixed at some point, as @Billghost pointed out.

Change 277179 abandoned by Umherirrender:
Apply setting variable instead of direct warning value

Reason:
This extension is ARCHIVED on gerrit

https://gerrit.wikimedia.org/r/277179