Page MenuHomePhabricator

TextContent constructed with $text = NULL
Closed, ResolvedPublic

Description

-rakkaus:#mediawiki-i18n- (1 lines skipped) [12-Feb-2013 08:41:53 UTC] PHP Notice: TextContent constructed with $text = NULL! This may indicate an error in the caller's scope. [Called from TextContent::__construct in /www/translatewiki.net/w/includes/content/TextContent.php at line 42] in /www/translatewiki.net/w/includes/debug/Debug.php on line 283

See also bug 41735.


Version: 1.21.x
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=41735

Details

Reference
bz44898

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.
StatusAssignedTask
OpenNone
Resolved Nikerabbit

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 1:20 AM
bzimport set Reference to bz44898.
bzimport added a subscriber: Unknown Object (MLST).
Nemo_bis created this task.Feb 12 2013, 9:27 AM

I would note that the message is useless as it does not specify the actual caller.

Created attachment 12709
More instances

Nikerabbit says "the message is useless".

Attached:

No longer observed.

(In reply to comment #3)

No longer observed.

Last instance was just yesterday, was that you testing? It usually appears in batches every month or two, probably caused by some user doing something rather special or by some specific page we've not yet found? Tentatively reopening.

2013-12-19 14.19 -rakkaus:#mediawiki-i18n- (2 lines skipped) [19-Dec-2013 13:19:58 UTC] PHP Notice: TextContent constructed with $text = NULL! This may indicate an error in the caller's scope. [Called from TextContent::__construct in /www/translatewiki.net/w/includes/content/TextContent.php at line 41] in /www/translatewiki.net/w/includes/debug/Debug.php on line 301

2013-09-27 10.58 -rakkaus:#mediawiki-i18n- [27-Sep-2013 08:58:52 UTC] PHP Notice: TextContent constructed with $text = NULL! This may indicate an error in the caller's scope. [Called from TextContent::__construct in /www/translatewiki.net/w/includes/content/TextContent.php at line 42] in /www/translatewiki.net/w/includes/debug/Debug.php on line 296

Change 102885 had a related patch set uploaded by Brian Wolff:
Make the warning from TextContent::__construct show caller.

https://gerrit.wikimedia.org/r/102885

(In reply to comment #5)

Change 102885 had a related patch set uploaded by Brian Wolff:
Make the warning from TextContent::__construct show caller.
https://gerrit.wikimedia.org/r/102885

That's not a fix to the issue, just a fix to comment 2.

Change 102885 merged by jenkins-bot:
Make the warning from TextContent::__construct show caller.

https://gerrit.wikimedia.org/r/102885

Nikerabbit closed this task as Resolved.Mar 29 2016, 12:40 PM
Nikerabbit claimed this task.

That fix was not very effective, since the new warning was:
Notice: TextContent constructed with $text = NULL! This may indicate an error in the caller's scope. [Called from WikitextContent::__construct

Anyway, the real reason was identified as T76014: Special:ImportTranslations: TextContent constructed with $text = NULL and fixed.

Closing this one.