Visual Editor: Bullet renders on last line for citation templates that span multiple lines
Closed, ResolvedPublic

Description

Firefox 22 on Linux showing citation templates in a bulleted list rendered in a narrow window

English Wikipedia user reports:
"If I open [[Leeds Festival (classical music)]] in VE, the first of the Sources is displayed with the bullet point on its second line, not the first. Looks very odd, comes into the category of "likely to make novice editor wonder what the hell is going on and what they've done to break the article".

It's reproducible: see [[User:PamD/sandbox for VE]]: looks fine until you go into VE, then items 1 and 3 in list show the dropped bulletpoint - they are {{tl|cite book}} and {{tl|cite web}} - while the flat text bullet points look normal. And making the window even narrower shows its the last line, not the second line, of a multiline entry which gets the bullet."

Permanent link to Pam's Sandbox page: https://en.wikipedia.org/w/index.php?title=User:PamD/sandbox_for_VE&oldid=565071087

I can reproduce this with citation templates, but not with a plain template designed to test it - [[User:Thryduulf/bullet-template]] - where the bullet renders on the same line https://en.wikipedia.org/w/index.php?title=User:Thryduulf/sandbox2&oldid=565096837


Version: unspecified
Severity: normal

Attached:

bzimport set Reference to bz51760.
Thryduulf created this task.Via LegacyJul 20 2013, 8:21 PM
Thryduulf added a comment.Via ConduitJul 20 2013, 8:23 PM

Possibly this is related to Bug 51708, but I'm doubtful

Aklapper closed this task as "Resolved".Via WebMar 4 2015, 4:35 PM
Aklapper claimed this task.
Aklapper added a subscriber: Aklapper.

Sorry that this has not received feedback earlier, and thanks for reporting this!

I cannot reproduce the problem anymore on https://en.wikipedia.org/w/index.php?title=Leeds_Festival_%28classical_music%29&oldid=565065526&veaction=edit (the version when this bug was reported) and the most recent revision - the bullet line is rendered correctly in Firefox 36 on Fedora 21. Same expected behavior on https://en.wikipedia.org/wiki/User:PamD/sandbox_for_VE . Maybe also fixed by T53708 which got fixed in the meantime.

I assume this problem has been fixed since it was reported.

If you still see this problem, please reopen this task and mention the URL/link that the problem can be seen at, your browser and version, and your operating system. Thank you!

Jdforrester-WMF triaged this task as "Normal" priority.Via WebWed, Aug 5, 12:14 AM
Jdforrester-WMF set Security to None.
Jdforrester-WMF set Story Points to 0.

Add Comment