Page MenuHomePhabricator

[Regression] Echo: Sending 2 e-mails for user talk page notification (1x HTML, 1x old style plain text) when you watch your own talk page
Closed, ResolvedPublic

Description

For this edit on my talk page[1]:

https://meta.wikimedia.org/w/index.php?title=User_talk%3AKrinkle&diff=5759862&oldid=5625192

I received two e-mail notifications:

From: Meta <no-reply-notifications@mediawiki.org>
To: Krinkle <krinklemail@gmail.com>
Reply-To: No Reply <no-reply-notifications@mediawiki.org>
Subject: Ricordisamoa left you a message on Meta
Date: Thu, 29 Aug 2013 21:59:02 +0000
View message:
https://meta.wikimedia.org/wiki/User_talk:Krinkle#User_talk:Krinkle.2FTools
View changes:
https://meta.wikimedia.org/w/index.php?title=User_talk:Krinkle&oldid=5759862&diff=prev

From: MediaWiki Mail <wiki@wikimedia.org>
To: Krinkle <krinklemail@gmail.com>
Reply-To: reply@not.possible
Subject: Meta page User talk:Krinkle has been changed by Ricordisamoa
Date: Thu, 29 Aug 2013 21:59:04 +0000
See

http://meta.wikimedia.org/w/index.php?title=User_talk:Krinkle&diff=next&oldid=5625192
to view this change.

Though the diff links are different, they are the same edit (one uses the revision id with diff=prev, the other uses the previous revision id with diff=next)

[1] https://meta.wikimedia.org/w/index.php?title=User_talk%3AKrinkle&action=history&year=2013&month=8


Version: unspecified
Severity: critical

Details

Reference
bz53569

Event Timeline

bzimport raised the priority of this task from to Unbreak Now!.Nov 22 2014, 2:05 AM
bzimport added a project: Notifications.
bzimport set Reference to bz53569.
bzimport added a subscriber: Unknown Object (MLST).
Krinkle created this task.Aug 29 2013, 10:57 PM

Also note that there is 3 different addresses used here, that should be normalised:

  • reply@not.possible
  • MediaWiki Mail <wiki@wikimedia.org>
  • Meta <no-reply-notifications@mediawiki.org>

My first thought is that they're all wrong. The first one is just terrible. The second one has a reasonable domain though it should contain "noreply" and the name of the wiki. The third one has the name of the wiki and noreply, but incorrectly uses mediawiki.org instead of wikimedia.org (or even meta.wikimedia.org).

bsitu wrote:

The text version looks like the legacy talk notification email, it should be disabled when Echo talk notification is enabled. Do you mind posting the full text version here? You can also send it to my email privately

Thanks,

Prioritization and scheduling of this bug is tracked on Mingle card https://mingle.corp.wikimedia.org/projects/flow/cards/240

As this has been highest priority for nearly four weeks now: Does somebody plan to work on this, or is this maybe not highest priority?

This has been "highest priority" (set by Krinkle) for three months now.

Either this issue is NOT highest priority and priority should be reset to something more realistic, or (wo)manpower needs to get assigned.

bsitu wrote:

Could it be that you have two accounts in meta with the same email address? One account is watching the talk page of another account so that when another user posts on your talk page, one account would receive an echo talk page notification, another account would receive a normal watchlist notification?

No, I don't think that's the case. I do have a bot account with the same email address, but that account has no watchlist (I verified).

I have this problem too. It's impossible to confuse the account which is receiving an email notification, because it's mentioned e.g. in the To: field.

bsitu wrote:

I was not able to reproduce this issue. The legacy talk page email notification should be disabled by this hook AbortTalkPageEmailNotification. There must be some use cases that I haven't encountered, I will need to do some more debugging. By the way, do you mind pasting the old talk page email notification here?

(In reply to comment #10)

I was not able to reproduce this issue.

It doesn't happen consistently. To me it happened on it.voy (where I have all notification checkboxes checked in the main Special:Preferences section, and all defaults in the Echo section).


To: Nemo bis
Subject: =?UTF-8?Q?La=20pagina=20Discussioni=20utente:Nemo=20bis=20di=20Wikivoyage=20=C3=A8=20stata=20modificata=20da=20Andyrom75?=
From: MediaWiki Mail <wiki@wikimedia.org>
Reply-To: reply@not.possible
Date: Tue, 03 Dec 2013 19:03:10 +0100
Message-ID: <itwikivoyage.529e1cde6026f6.93632240@it.wikivoyage.org>
X-Mailer: MediaWiki mailer
MIME-Version: 1.0
Content-type: text/plain; charset=UTF-8
Content-transfer-encoding: 8bit

Gentile Nemo bis,

La pagina Discussioni utente:Nemo bis di Wikivoyage è stata modificata
da Andyrom75 il 3 dic 2013, vedi
http://it.wikivoyage.org/wiki/Discussioni_utente:Nemo_bis per la
versione attuale.

Visita
http://it.wikivoyage.org/w/index.php?title=Discussioni_utente:Nemo_bis&diff=next&oldid=321040
per vedere la modifica.

Visita
http://it.wikivoyage.org/w/index.php?title=Discussioni_utente:Nemo_bis&diff=0&oldid=321040
per vedere tutte le modifiche dall'ultima visita.

Oggetto dell'intervento, inserito dall'autore: /* Ricerca & Bug */ nuova
sezione

Contatta l'autore:
via posta elettronica:
http://it.wikivoyage.org/wiki/Speciale:InviaEMail/Andyrom75
sul sito: http://it.wikivoyage.org/wiki/Utente:Andyrom75

Non verranno inviate altre notifiche in caso di ulteriori attività, se
non visiti la pagina. Inoltre, è possibile modificare le impostazioni
di notifica per tutte le pagine nella lista degli osservati speciali.

Il sistema di notifica di Wikivoyage, al tuo servizio

Per modificare le impostazioni delle notifiche via posta elettronica,
visita
http://it.wikivoyage.org/wiki/Speciale:Preferenze

Per modificare la lista degli osservati speciali, visita
http://it.wikivoyage.org/wiki/Speciale:ModificaOsservati

Per rimuovere la pagina dalla lista degli osservati speciali, visita
http://it.wikivoyage.org/w/index.php?title=Discussioni_utente:Nemo_bis&action=unwatch

Per commentare e ricevere aiuto:
http://it.wikivoyage.org/wiki/Aiuto:Aiuto


To: Nemo bis
Subject: Andyrom75 ti ha lasciato un messaggio in Wikivoyage
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="=_9ff2361c269d488307d72f53351c7107"
From: Wikivoyage <no-reply-notifications@mediawiki.org>
Reply-To: No Reply <no-reply-notifications@mediawiki.org>
Date: Tue, 03 Dec 2013 19:03:09 +0100
Message-ID: <itwikivoyage.529e1cdd7df2b3.84597938@it.wikivoyage.org>
X-Mailer: MediaWiki mailer

--=_9ff2361c269d488307d72f53351c7107
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain; charset=UTF-8

Andyrom75 ha lasciato un messaggio sulla tua pagina di discussione in 'Rice=
rca & Bug'.

Ok per la ricerca, mi sembra utile. Dopo lo implemento.
Per quanto riguarda il bug che ho segnalato a Wim e Jalo non =C3=A8 che mi =
sai dare una mano? --

Vedi messaggio: <https://it.wikivoyage.org/wiki/Discussioni_utente:Nemo_bis=
#Ricerca_.26_Bug>

Vedi modifiche: <https://it.wikivoyage.org/w/index.php?title=3DDiscussioni_=
utente:Nemo_bis&oldid=3Dprev&diff=3D323083>

Per controllare quali email ti verranno inviate, controlla le tue preferenz=
e:
http://it.wikivoyage.org/wiki/Speciale:Preferenze#mw-prefsection-echo

Wikimedia Foundation, 149 New Montgomery St., 3rd Fl., San Francisco, CA 94=
105, USA
--=_9ff2361c269d488307d72f53351c7107
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html; charset=UTF-8

<html><head>
<meta http-equiv=3D"Content-Type" content=3D"text/html; charset=3DUTF-8" /=

<meta name=3D"viewport" content=3D"width=3Ddevice-width, initial-sc=

ale=3D1.0" />
<style>

		@media only screen and (max-width: 480px){
			table[id=3D"email-container"]{max-width:600px !important; width:100% !im=

portant;}

		}

</style>
</head><body>
<table cellspacing=3D"0" cellpadding=3D"0" border=3D"0" width=3D"100%" alig=
n=3D"center" lang=3D"it" dir=3D"ltr">
<tr>
<td bgcolor=3D"#E6E7E8"><center>

		<br /><br />
		<table cellspacing=3D"0" cellpadding=3D"0" border=3D"0" width=3D"600" id=

3D"email-container">

			<tr>
				<td bgcolor=3D"#FFFFFF" width=3D"5%">&nbsp;</td>
				<td bgcolor=3D"#FFFFFF" width=3D"10%">&nbsp;</td>
				<td bgcolor=3D"#FFFFFF" width=3D"80%" style=3D"line-height:40px;">&nbsp=

;</td>

				<td bgcolor=3D"#FFFFFF" width=3D"5%">&nbsp;</td>
			</tr><tr>
				<td bgcolor=3D"#FFFFFF" rowspan=3D"2">&nbsp;</td>
				<td bgcolor=3D"#FFFFFF" align=3D"center" valign=3D"top" rowspan=3D"2"><=

img src=3D"http://bits.wikimedia.org/static-1.23wmf4/extensions/Echo/module=
s/icons/Talk.png" alt=3D"" height=3D"30" width=3D"30"></td>

				<td bgcolor=3D"#FFFFFF" align=3D"left" style=3D"font-family: Arial, Hel=

vetica, sans-serif; font-size:13px; line-height:20px; color:#6D6E70;"><a hr=
ef=3D"https://it.wikivoyage.org/wiki/Utente:Andyrom75" title=3D"Utente:Andy=
rom75" style=3D"text-decoration: none; color: #3A68B0;">Andyrom75</a> ha la=
sciato un messaggio sulla tua pagina di discussione in 'Ricerca &amp; Bug'=

2E</td>

				<td bgcolor=3D"#FFFFFF" rowspan=3D"2">&nbsp;</td>
			</tr><tr>
				<td bgcolor=3D"#FFFFFF" align=3D"left" style=3D"font-family: Arial, Hel=

vetica, sans-serif; line-height: 20px; font-weight: 600;">

					<table cellspacing=3D"0" cellpadding=3D"0" border=3D"0">
						<tr>
							<td bgcolor=3D"#FFFFFF" align=3D"left" style=3D"font-family: Arial, =

Helvetica, sans-serif; padding-top: 8px; font-size:13px; font-weight: bold;=
color: #58585B;">

								Ok per la ricerca, mi sembra utile. Dopo lo implemento.

Per quanto riguarda il bug che ho segnalato a Wim e Jalo non =C3=A8 che mi =
sai dare una mano? --

							</td>
						</tr>
					</table>
					<table cellspacing=3D"0" cellpadding=3D"0" border=3D"0">
						<tr>
							<td bgcolor=3D"#FFFFFF" align=3D"left" style=3D"font-family: Arial, =

Helvetica, sans-serif; font-size:14px; padding-top: 25px;">

								<a href=3D"https://it.wikivoyage.org/wiki/Discussioni_utente:Nemo_b=

is#Ricerca_.26_Bug" title=3D"Discussioni utente:Nemo bis" class=3D"mw-echo-=
notification-primary-link" style=3D"cursor:pointer; text-align:center; text=
-decoration:none; padding:.45em 1.2em .45em;&#10;&#9;&#9;&#9;color:#D9EEF7;=
background:#3366BB; font-family: Arial, Helvetica, sans-serif;font-size: 1=
3px;">Vedi messaggio</a>&nbsp;&nbsp;<a href=3D"https://it.wikivoyage.org/w/=
index.php?title=3DDiscussioni_utente:Nemo_bis&amp;oldid=3Dprev&amp;diff=3D3=
23083" title=3D"Discussioni utente:Nemo bis" class=3D"mw-echo-notification-=
secondary-link" style=3D"text-decoration: none;font-size: 10px;font-family:=
Arial, Helvetica, sans-serif; color: #808184">Vedi modifiche</a>

							</td>
						</tr>
					</table>
				</td>
			</tr><tr>
				<td bgcolor=3D"#FFFFFF">&nbsp;</td>
				<td bgcolor=3D"#FFFFFF">&nbsp;</td>
				<td bgcolor=3D"#FFFFFF" style=3D"line-height:40px;">&nbsp;</td>
				<td bgcolor=3D"#FFFFFF">&nbsp;</td>
			</tr><tr>
				<td bgcolor=3D"#F8F8F8">&nbsp;</td>
				<td bgcolor=3D"#F8F8F8">&nbsp;</td>
				<td bgcolor=3D"#F8F8F8" align=3D"left" style=3D"font-family: Arial, Hel=

vetica, sans-serif; font-size:10px; line-height:13px; color:#6D6E70; paddin=
g:10px 20px;"><br />

					Per verificare quali email ti vengono inviate, <a href=3D"https://it=

2Ewikivoyage.org/wiki/Speciale:Preferenze#mw-prefsection-echo" style=3D"te

xt-decoration:none; color: #3868B0;">controlla le tue preferenze</a><br />
Wikimedia Foundation, 149 New Montgomery St., 3rd Fl., San Francisco, CA 94=
105, USA

					<br /><br />
				</td>
				<td bgcolor=3D"#F8F8F8">&nbsp;</td>
			</tr><tr>
				<td colspan=3D"4">&nbsp;</td>
			</tr>
		</table>
		<br><br></center>

</td>
</tr>
</table>
</body></html>
--=_9ff2361c269d488307d72f53351c7107--

(In reply to comment #1)

the name of the wiki and noreply, but
incorrectly uses mediawiki.org instead of wikimedia.org (or even
meta.wikimedia.org).

Every single mail header is inconsistent between the old and new notifications, that's by design. This part however is surely a bug: filed as bug 58261.

bsitu wrote:

I found out the source of the bug, it happens when you are watching your own talk page, the other email is basically a watchlist email. Echo doesn't interfere with watchlist notifications. I will see what can be done there

(In reply to comment #14)

I found out the source of the bug, it happens when you are watching your own
talk page, the other email is basically a watchlist email. Echo doesn't
interfere with watchlist notifications. I will see what can be done there

Ok, I see you use the AbortTalkPageEmailNotification core hook for that, but there isn't such a thing for enotifwatchlist so I assume this will also require a core change. While you're at it, it would be nice if you could also (partially?) fix bug 42458 at the same time (or we could call that a blocker of this).

(In reply to comment #14 by bsitu)

I found out the source of the bug, it happens when you are watching your own
talk page, the other email is basically a watchlist email. Echo doesn't
interfere with watchlist notifications. I will see what can be done there

bsitu: Any news / updates?

bsitu wrote:

(In reply to comment #16)

(In reply to comment #14 by bsitu)

I found out the source of the bug, it happens when you are watching your own
talk page, the other email is basically a watchlist email. Echo doesn't
interfere with watchlist notifications. I will see what can be done there

bsitu: Any news / updates?

Andre: No, there is no progress on this one yet. I will pick it up when I am not flowing, :)

As a reminder, every single new user on our wikis (per bug 49719) is currently receiving double emails for any message posted on their talk page. Surely this deserves some action? Does someone need to write some vitriolic mailing list message on how receiving such spam will most likely contribute alienating new users from our wikis, making them disable any and all email notifications and making us lose any way to contact and reactivate them in the future?

(In reply to comment #18)

As a reminder, every single new user on our wikis (per bug 49719) is
currently
receiving double emails for any message posted on their talk page. Surely
this
deserves some action? Does someone need to write some vitriolic mailing list
message on how receiving such spam will most likely contribute alienating new
users from our wikis, making them disable any and all email notifications and
making us lose any way to contact and reactivate them in the future?

The probably don't have "Email me when a page or file on my watchlist is changed" checked.

Right, exclude the WMF wikis from the "our wikis" above, it's only the tens thousands other wikis. :) I always have a hard time convincing myself bug 38796 is still open.

Change 114682 had a related patch set uploaded by Bsitu:
Add new Hook 'SendWatchlistEmailNotification'

https://gerrit.wikimedia.org/r/114682

Change 114683 had a related patch set uploaded by Bsitu:
Prevent double email notifications on talk page edit

https://gerrit.wikimedia.org/r/114683

Change 114682 merged by jenkins-bot:
Add new Hook 'SendWatchlistEmailNotification'

https://gerrit.wikimedia.org/r/114682

(In reply to Gerrit Notification Bot from comment #23)

Change 114683 had a related patch set uploaded by Bsitu:
Prevent double email notifications on talk page edit
https://gerrit.wikimedia.org/r/114683

Can this patch please get reviewed and merged so this highest prio ticket can get closed? It's been open for more than six months now. Thanks.

Change 114683 merged by jenkins-bot:
Prevent double email notifications on talk page edit

https://gerrit.wikimedia.org/r/114683

(In reply to Gerrit Notification Bot from comment #26)

Change 114683 merged by jenkins-bot:
Prevent double email notifications on talk page edit

Patch merged; is there more work to do or can this be closed as FIXED?

I'm no longer able to reproduce on it.voy, though that's on 1.23wmf18 (without the fix for this bug)...

Quiddity removed a subscriber: Maryana.Dec 19 2014, 1:22 AM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJan 28 2016, 5:57 PM