Page MenuHomePhabricator

MediaWiki broken with IPv6
Closed, ResolvedPublic

Description

Author: oyvinds

Description:

  1. Install MediaWiki
  2. Test with IPv4
  3. Add IPv6 using exactly the same VHOST settings

[78219220] /Unofficial_Bitfinex_Wiki Exception from line 1169 of /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/WebRequest.php: Unable to determine IP.

Backtrace:

#0 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/User.php(1769): WebRequest->getIP()
#1 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/db/Database.php(945): User->getName()
#2 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/db/Database.php(1496): DatabaseBase->query(string, string)
#3 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/db/Database.php(1585): DatabaseBase->select(string, array, array, string, array, array)
#4 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/Revision.php(1491): DatabaseBase->selectRow(string, array, array, string)
#5 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/Revision.php(1029): Revision->loadText()
#6 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/Revision.php(974): Revision->getContentInternal()
#7 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/WikiPage.php(636): Revision->getContent(integer, NULL)
#8 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/WikiPage.php(465): WikiPage->getContent()
#9 [internal function]: WikiPage->isRedirect()
#10 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/Article.php(2028): call_user_func_array(array, array)
#11 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/Wiki.php(382): Article->__call(string, array)
#12 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/Wiki.php(382): Article->isRedirect()
#13 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/Wiki.php(302): MediaWiki->initializeArticle()
#14 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/Wiki.php(602): MediaWiki->performRequest()
#15 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/includes/Wiki.php(467): MediaWiki->main()
#16 /home/httpd/vhosts/bfxwiki.everdot.org/httpdocs/index.php(49): MediaWiki->run()
#17 {main}

Wiki works just fine - as long as you connect using IPv4. IPv6 works fine with previous versions of MediaWiki and I enabled support for IPv6 on most of my wiki's so I guess I won't be "upgrading" those to 1.22.0.


Version: 1.22.0
Severity: blocker

Details

Reference
bz58253

Event Timeline

bzimport raised the priority of this task from to Needs Triage.
bzimport set Reference to bz58253.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Dec 10 2013, 4:46 AM

Can you tell us the names and versions of:

a) operating system or Linux distribution
b) HTTP server software (e.g. Apache)

As well as the following information from phpinfo() or php -i:

c) PHP version
d) PCRE version

I'm trying to figure out whether or not this is the same issue as bug 58213.

oyvinds wrote:

I am guessing it IS the same issue as bug 58213, sorry for not finding it (I did search for ipv6 here but did not see that). I guess it is duplicate due to me using basically the same setup.

cat /etc/redhat-release

CentOS release 5.9 (Final)

apachectl -v

Server version: Apache/2.2.3

php --version

PHP 5.3.3 (cli) (built: Jul 12 2013 17:04:59)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

]# rpm -qa | grep pcre
pcre-6.6-6.el5_6.1
pcre-devel-6.6-6.el5_6.1

oyvinds wrote:

php -i as requested

Attached:

  • This bug has been marked as a duplicate of bug 58213 ***

As noted on the duplicate, this is an issue with CentOS shipping a pcre version which is like six years old and should really be upgraded by CentOS.

(In reply to comment #5)

As noted on the duplicate, this is an issue with CentOS shipping a pcre
version
which is like six years old and should really be upgraded by CentOS.

The problem is that recommended instructions to upgrade from CentOS 5 to CentOS 6 are basically "install CentOS 6 on a new machine, then copy your user data over".[1] :/

[1]: http://wiki.centos.org/HowTos/MigrationGuide/MigratingFiveToSix

oyvinds wrote:

should really be upgraded

This is not going to happen.

You can keep supporting a widely deployed server operating system or in practise encurage people to just stop upgrading MediaWiki. This is the choice we will be making for now.

Reality is that users like me try the latest version of MediaWiki and find that it is broken. I feel lucky that I found out that MediaWiki 1.22 is broken on Centos 5.9 during the setup of a new wiki, now I know I should not even consider upgrading other MediaWiki installations on our servers until we upgrade the servers (and move to Centos 6.x) 6 months to a year from now. We'll be running old MW in the meantime.

"CentOS shipping a pcre version which is like six years old and should really be upgraded by CentOS" is like saying "everyone should be nice to each other". Sure, that would be great but reality is that it ain't going to happen. As for MW, people will just say "latest version is broken" and not use it.

I don't know how much work would be involved in making it work on CentOS 5.x but if it's just a matter of changing a few lines of code then you should just do it.

(In reply to comment #7)

I don't know how much work would be involved in making it work on CentOS 5.x
but if it's just a matter of changing a few lines of code then you should
just do it.

Copying the Marks and cross-referencing with [[mw:MediaWiki 1.22/Known issues]].