Page MenuHomePhabricator

Investigate Media Viewer metrics for last improvements
Closed, ResolvedPublic

Description

Verify that latest metrics dashboards are correct (especially why there seems to be a decline for clicks on author, source, license and terms). Also check the metadata panel open/close, to make sure it includes both up/down arrow keys and scrolling.

See below latest metrics findings related to this card.


Metrics

EventLogging outage over. The backfilling has happened and it turns out that previsouly seen trends have vanished.
For example fullscreen usage is following exactly the same trend as image views, where previously it appeared to be declining: https://www.dropbox.com/s/f1ew5oykd5qlgw0/Screenshot%202014-11-25%2009.35.50.png?dl=0

Views on the rise: https://www.dropbox.com/s/irdax6lub7p47tz/Screenshot%202014-11-25%2009.41.01.png?dl=0
This is coming from all sources (thumbnail clicks, hash loads, etc.)

Panel access seems to have dropped since the UI update, although it rises again, we should follow this closely: https://www.dropbox.com/s/a3twie4bxdzxmgo/Screenshot%202014-11-25%2009.38.40.png?dl=0

Sharp drop in "terms open" action: https://www.dropbox.com/s/6xzg8hedypn2s43/Screenshot%202014-11-25%2009.39.15.png?dl=0

Similar drop for the license/author/source pages action: https://www.dropbox.com/s/iqyma0481o5tamr/Screenshot%202014-11-25%2009.39.34.png?dl=0

Bottom links traffic going down, except for "discuss" which is shooting through the roof: https://www.dropbox.com/s/ylwf3d5zx7040o4/Screenshot%202014-11-25%2009.40.20.png?dl=0

A slight spike in optouts on the 20th and then back to normal levels: https://www.dropbox.com/s/zrrn4bsji1nuzmm/Screenshot%202014-11-25%2009.43.16.png?dl=0

Event Timeline

Fabrice_Florin updated the task description. (Show Details)
Fabrice_Florin raised the priority of this task from to Needs Triage.
Fabrice_Florin added a project: Multimedia.
Fabrice_Florin changed Security from none to None.
Fabrice_Florin triaged this task as High priority.Nov 26 2014, 5:50 PM
Gilles added a comment.Dec 3 2014, 3:43 PM

Views don't seem to be rising anymore, it was probably a seasonal change.

The patch to track scroll opens hasn't landed yet.

We still have to explain the drop in terms/license/author/source.

I've double checked the action tracking for license/author/source and it's working fine. This is a genuine drop of clicks for everything except for metadata open/close, which we know was caused by the fact that we weren't track scroll-only opens (only chevron click and key presses).

Soon we'll track scroll-induced opening of the metadata, but there won't be historical data to compare to.

I think this is an indication that everything in the darker grey area is seeing less clicks than before. However it isn't an indication that the below-the-fold area is being scrolled less, because the drop is more drastic for the above-the-fold grey area actions (license, author, source), than it is for below-the-fold ones (uploader, bottom links).

I think it's an interesting unexpected turn of events that the above-the-fold darker area is the one that people are being the most "blind to" as a result of the changes.

Gilles moved this task from Next up to Doing on the Multimedia board.Dec 16 2014, 10:38 AM
Gilles moved this task from Doing to Done on the Multimedia board.Dec 18 2014, 8:49 AM
Gilles closed this task as Resolved.