Page MenuHomePhabricator

P3. "Edited by 45 years ago" message for all JS-rendered timestamps
Closed, ResolvedPublic1 Story Points

Description

JS-rendered timestamps are showing as "Edited by 45 years ago" locally, apparently without regard for whether they have actually been edited.

Event Timeline

Mattflaschen-WMF claimed this task.
Mattflaschen-WMF raised the priority of this task from to Unbreak Now!.
Mattflaschen-WMF updated the task description. (Show Details)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 14 2015, 11:14 PM
Mattflaschen-WMF lowered the priority of this task from Unbreak Now! to Normal.Jan 15 2015, 12:09 AM

Only applies with https://gerrit.wikimedia.org/r/#/c/182858/ (I happened to have that checked out), but we need to solve this before that can be merged.

Mattflaschen-WMF raised the priority of this task from Normal to High.Jan 15 2015, 5:02 AM

The ball is back in our court. For now, we need to use ApiResult::META_BC_BOOLS . See https://gerrit.wikimedia.org/r/#/c/182858/ .

gerritbot added a subscriber: gerritbot.

Change 180755 had a related patch set uploaded (by Matthias Mullie):
JS-generated timestamps have no hover, only displays readable time

https://gerrit.wikimedia.org/r/180755

Patch-For-Review

Note: unsure if above patch is related to/fixes this specific issue.

I don't think so. Also, this bug shouldn't appear on core master yet, only with the patch linked above.

I added this to the sprint, because we're blocking that core change. I don't think it's super high-priority yet (we're not the only thing blocking it), but I don't want to forget about it.

Mattflaschen-WMF renamed this task from "Edited by 45 years ago" message for all JS-rendered timestamps to [1] "Edited by 45 years ago" message for all JS-rendered timestamps.Jan 28 2015, 7:58 PM
DannyH renamed this task from [1] "Edited by 45 years ago" message for all JS-rendered timestamps to [1] P3. "Edited by 45 years ago" message for all JS-rendered timestamps.Jan 30 2015, 6:37 PM
DannyH renamed this task from [1] P3. "Edited by 45 years ago" message for all JS-rendered timestamps to P3. "Edited by 45 years ago" message for all JS-rendered timestamps.Feb 3 2015, 6:52 PM

Change 189171 had a related patch set uploaded (by Mattflaschen):
WIP: Add backwards-compat metadata so booleans keep working right

https://gerrit.wikimedia.org/r/189171

Patch-For-Review

Change 189171 merged by jenkins-bot:
Add backwards-compat metadata so booleans keep working right

https://gerrit.wikimedia.org/r/189171

Mattflaschen-WMF closed this task as Resolved.Feb 18 2015, 12:28 AM
Quiddity reopened this task as Open.Mar 11 2015, 9:18 PM
Quiddity added a subscriber: Quiddity.

An editor says they are still seeing this bug at mediawiki. I'm unable to reproduce, but perhaps it's an IE/Windows specific bug? I've asked for more details at https://www.mediawiki.org/wiki/Topic:Sami9qe4icwmyz4x

This should never have been visible to end users. It was done in preparation for https://gerrit.wikimedia.org/r/#/c/182858/ , which is not yet merged.

If someone's seeing this, it's probably a separate cause, and we need more info to track it down. (Note, I don't see any mention in the OP about locking).

Anomie added a subscriber: Anomie.

If the claim is that this is happening now, then it can't be blocking T76728.

Quiddity closed this task as Resolved.Mar 16 2015, 11:48 PM