Page MenuHomePhabricator

The new default workboard view of projects does not highlight the workboard icon
Closed, DuplicatePublic

Description

  1. In phabricator Search for a project, e.g. MediaWiki-RfCs Collaboration-Team-Triage
  2. follow the link to https://phabricator.wikimedia.org/tag/MediaWiki-RfCs

Result:
The link is to /tag/project-name. In a recent (and controversial - T89865 ) Phabricator change this shows the project workboard with all tasks. But in the column of project icons on the left, the Workboard (two columns) icon is not highlighted. The project icon has a color, so it looks like you are viewing that mode, but that is a different view, /project/profile/project-name

Clicking the the workboard icon takes you to /project/board/NNN and highlitghts its icon. , This is a different URL than /tag/project-name , but appears similar.

Expected result:
If visiting /tag/project-name shows the project workboard (i.e. this change isn't reverted), then the project workboard icon should highlight to indicate that's what you're seeing.

Event Timeline

Spage raised the priority of this task from to Needs Triage.
Spage updated the task description. (Show Details)
Spage added a subscriber: Spage.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 25 2015, 7:57 PM
Qgil added a subscriber: Qgil.
Aklapper triaged this task as Low priority.Feb 26 2015, 2:00 PM
Aklapper edited projects, added Phabricator; removed Phabricator (Upstream).
Aklapper set Security to None.

Seems to be a downstream issue. Cannot reproduce in upstream. Naively wondering if Sprint extension is involved (not that I have any evidence but don't know about other custom stuff involving this area).

Only happens at first access, clicking the Workboard icon in the project pane on the left highlights it after reloading.

Seems to be a downstream issue. Cannot reproduce in upstream. Naively wondering if Sprint extension is involved (not that I have any evidence but don't know about other custom stuff involving this area).

Maybe. I just noticed another bug, T91042: The icons for Sprint Board and Burndown view don't display an active blue on gray state.

Only happens at first access, clicking the Workboard icon in the project pane on the left highlights it after reloading.

Yes. As I said in the description, clicking the the workboard icon goes to a different URL, /project/board/NNN, than /tag/project-name, even though both show the workboard (latter is controversial, T89865}.