Page MenuHomePhabricator

Make MobileFrontend add a mobile rel=alternative to the desktop version instead of noindexing mobile pages
Closed, ResolvedPublic

Description

MobileFrontend appears to use an $wgMFNoindexPages that defaults to true (according to the extension page) to simply block indexing of mobile as a way of handling indexing "issues".

I believe the correct way to handle this is not to noindex but instead to include a rel=alternative with a media="..." pointing to the mobile site. The way that google describes.

Event Timeline

DanielFriesen raised the priority of this task from to Needs Triage.
DanielFriesen updated the task description. (Show Details)
DanielFriesen added a subscriber: DanielFriesen.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 1 2015, 3:24 AM
Florian claimed this task.Mar 1 2015, 10:53 PM

Change 193756 had a related patch set uploaded (by Florianschmidtwelzow):
Hygiene: Correctly show relationship between desktop and mobile page

https://gerrit.wikimedia.org/r/193756

Change 193756 merged by jenkins-bot:
Hygiene: Correctly show relationship between desktop and mobile page

https://gerrit.wikimedia.org/r/193756

Florian closed this task as Resolved.Mar 2 2015, 11:41 AM
Florian reopened this task as Open.Mar 11 2015, 8:22 AM

Can someone check the behavior on wikisource.org (group1, the change was deployed yesterday). At least on the desktop site it seems to not work? And if you click the mobile link, the canonical link seems to be false formatted, too, or is it just on my site (maybe a caching issue)? :/

Florian triaged this task as High priority.Mar 11 2015, 8:22 AM
Florian added a project: Readers-Web-Backlog.
Florian moved this task from Incoming to 2014-15 Q4 on the Readers-Web-Backlog board.
Florian removed Florian as the assignee of this task.Apr 6 2015, 6:25 PM
Florian added a subscriber: Florian.
Jdlrobson closed this task as Resolved.Apr 16 2015, 12:32 AM
Jdlrobson claimed this task.
Jdlrobson added a subscriber: Jdlrobson.

This is working.
If you want to enable it you'll need to flip the switch here:
http://git.wikimedia.org/blob/operations%2Fmediawiki-config.git/a7a32ef59f19cdb5c4ef409724280c2f2b56d7d2/wmf-config%2Fmobile.php#L9

I suggest raising a bug/making the config change for that if that is indeed the intended behaviour.

Change 212021 had a related patch set uploaded (by Florianschmidtwelzow):
Hygiene: Correctly add alternate and canocial links

https://gerrit.wikimedia.org/r/212021

Change 212022 had a related patch set uploaded (by Florianschmidtwelzow):
Enable alternate and canonical links for mobile/desktop pages

https://gerrit.wikimedia.org/r/212022

Change 212022 abandoned by Florianschmidtwelzow:
Enable alternate and canonical links for mobile/desktop pages

Reason:
can be done later, too, it's just a small change, and there is some work that need to be done before this change.

https://gerrit.wikimedia.org/r/212022

Florian set Security to None.