Page MenuHomePhabricator

Visual Editor save dialog hangs, causing data loss
Closed, DuplicatePublic

Description

I saw two VE data loss save failures this weekend. In each case, the user hit "save page" and the dialog just froze forever. The data was not written, and the "resume editing" button no longer worked, so data was lost (hence high priority).

If it is helpful for debugging, the first time was by enwiki user Cindyshih around 00:00 UTC Mar. 7/8 in her personal namespace (apparently she never came back to finish/retry the edit, so I don't know the exact name of the page she was editing), and I then saw it again on https://en.wikipedia.org/w/index.php?title=Bessie_Harvey about 30 minutes ago.

Event Timeline

LuisVilla created this task.Mar 9 2015, 2:20 AM
LuisVilla updated the task description. (Show Details)
LuisVilla raised the priority of this task from to High.
LuisVilla added a project: VisualEditor.
LuisVilla added a subscriber: LuisVilla.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 9 2015, 2:20 AM
Krenair added a subscriber: Krenair.EditedMar 9 2015, 2:30 AM

What was the error shown in the console? Does anyone know how we can reproduce this issue?

Posting explanations how to use the browser's console (if there is a problem or an error with JavaScript it should be printed in that console), as this might help our community to provide the information that developers need here:

Browser name and version is also welcome.

Obviously hard to get to a console after the fact :) I'll take a look if it happens again.

T91158: [Regression] VisualEditor no long able to rescue itself from badtoken error state on save was fixed just before this bug was filed. If no one runs into this for a few more weeks, I think it's safe to assume it was the same issue.

Good point; let's merge them for now.