Page MenuHomePhabricator

graphs for Cassandra metrics
Closed, ResolvedPublic

Description

We need graphs setup for most/all of the Cassandra metrics we are collecting, (including those to be added by https://gerrit.wikimedia.org/r/199264). I know that as it stands now, you can build ad hoc plots in Graphite as needed, but having these predefined ahead of time lowers the barrier to getting at the data. It's also not going to be obvious to everyone from looking at the metric names/hierarchy, what these values mean. Having these readied ahead of time means that metrics can be grouped to graphs, and graphs to pages, in whatever way makes sense (CF statistics, caching, repair, etc), with contextually appropriate labels, aggregation, and scaling.

Depending on the tooling available, this is potentially a lot of work (we're talking about quite a few graphs).

One option is Graphite, but I'm unable to log in due to T93158, so I'm not sure how easy this would be there. Grafana would probably work, it's templating seems to be a good fit for this kind of thing (http://docs.grafana.org/reference/templating), but I have many problems doing even the simplest of things (adding graph panels, deleting dashboards, etc). It also seems to be wide-open to vandalism (T93710).

Event Timeline

Eevans created this task.Mar 25 2015, 2:17 PM
Eevans updated the task description. (Show Details)
Eevans raised the priority of this task from to Needs Triage.
Eevans added subscribers: Eevans, GWicke.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 25 2015, 2:17 PM
Eevans set Security to None.Mar 25 2015, 2:18 PM
Eevans added subscribers: mobrovac, fgiunchedi.
fgiunchedi triaged this task as Normal priority.Mar 30 2015, 3:05 PM

I'm assuming you have graphite access now, in any case check out also https://gdash.wikimedia.org/ and related puppet module if that suits

Eevans closed this task as Resolved.Jun 25 2015, 7:40 PM
Eevans claimed this task.

Duplicate of T101764

Restricted Application added a subscriber: Matanya. · View Herald TranscriptJun 25 2015, 7:40 PM