Page MenuHomePhabricator

Edit toolbar does not appear (NS_ERROR_FILE_CORRUPTED)
Closed, DeclinedPublic

Description

Sometimes when i edit pages (&action=edit) on rowiki edit toolbar does not appear. In console i found this:

"[Exception... "File error: Corrupted" nsresult: "0x8052000b (NS_ERROR_FILE_CORRUPTED)" location: "JS frame :: https://bits.wikimedia.org/ro.wikipedia.org/load.php?debug=false&lang=ro&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T204712Z :: flush :: line 173" data: no]" Exception { message: "", result: 2152857611, name: "NS_ERROR_FILE_CORRUPTED", filename: "https://bits.wikimedia.org/ro.wikipedia.org/load.php?debug=false&lang=ro&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T204712Z", lineNumber: 173, columnNumber: 0, inner: null, data: null, stack: "flush@https://bits.wikimedia.org/ro.wikipedia.org/load.php?debug=false&lang=ro&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T204712Z:173:721
" } load.php:175:593
"[Exception... "File error: Corrupted" nsresult: "0x8052000b (NS_ERROR_FILE_CORRUPTED)" location: "JS frame :: https://bits.wikimedia.org/ro.wikipedia.org/load.php?debug=false&lang=ro&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T204712Z :: flush :: line 173" data: no]" Exception { message: "", result: 2152857611, name: "NS_ERROR_FILE_CORRUPTED", filename: "https://bits.wikimedia.org/ro.wikipedia.org/load.php?debug=false&lang=ro&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T204712Z", lineNumber: 173, columnNumber: 0, inner: null, data: null, stack: "flush@https://bits.wikimedia.org/ro.wikipedia.org/load.php?debug=false&lang=ro&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=20150408T204712Z:173:655
" }

Is this an issue caused by core MediaWiki, or can be also caused by some userscripts?

Event Timeline

XXN created this task.Apr 14 2015, 4:57 PM
XXN raised the priority of this task from to Needs Triage.
XXN updated the task description. (Show Details)
XXN added a subscriber: XXN.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 14 2015, 4:57 PM
XXN set Security to None.
He7d3r updated the task description. (Show Details)Apr 14 2015, 7:24 PM
He7d3r added a subscriber: He7d3r.

Is this about the classic toolbar or the toolbar from WikiEditor?

XXN added a comment.Apr 14 2015, 7:33 PM

WikiEditor toolbar

Paladox added a subscriber: Paladox.EditedDec 10 2015, 11:54 AM

Could this be closed as Declined since I visited the page as it is in the picture and the edit bar shows.

Tested on iPhone 6 safari on the main desktop site.

Tested at https://ro.wikipedia.org/w/index.php?title=Format:Redirect_categorie&action=edit

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptDec 10 2015, 11:54 AM
TheDJ closed this task as Declined.Dec 10 2015, 11:56 AM
TheDJ claimed this task.

Can't fix, since it's a problem with FF's localStorage sanity

GOIII moved this task from Backlog to Closed on the WikiEditor board.Apr 3 2016, 9:08 AM