Page MenuHomePhabricator

In category pages page links may jump to another column when clicked
Closed, ResolvedPublic

Description

With Chrome and Chromium when last link of the column is clicked in category page it may jump to next column and ignore the click. When browser refreshes/redraws the page the link will jump back to the original column. Problem is not category pages specific and it seems to happen also in other lists where "column-width" is used.

Problem is reported when Chrome or Chromium is used with Mac, Linux or Windows platforms. With Safari and Firefox bug doesn't happen.

How to repeat the bug

  1. Go to category page with Chrome: https://en.wikipedia.org/wiki/Category:Turku
  2. Re-size browser window so that there is only one column
  3. click last link of the column (should be "Turku sub-region" which is last element of the column)
    1. Result should be that clicked link will disappear
    2. and if you click again to the empty space where link was it should return.

Origin of the problem seems to be CSS-rule " ul { margin: 0.3em 0 0 1.6em }" which comes from modules mediawiki.skinning.interface and mediawiki.legacy.shared

Temporary fix in fiwiki diff:

mediawiki:common.css
ul {
	margin-bottom: 0.5em !important;	
}

Discussions of the bug in fiwiki

Event Timeline

Zache created this task.May 17 2015, 12:08 PM
Zache raised the priority of this task from to Needs Triage.
Zache updated the task description. (Show Details)
Zache added a project: MediaWiki-Categories.
Zache added a subscriber: Zache.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 17 2015, 12:08 PM
Zache updated the task description. (Show Details)May 17 2015, 12:22 PM
Zache set Security to None.
Zache updated the task description. (Show Details)May 17 2015, 12:25 PM
Zache updated the task description. (Show Details)May 17 2015, 12:38 PM
Edokter added a comment.EditedMay 17 2015, 1:32 PM

Chrome bug to monitor: https://code.google.com/p/chromium/issues/detail?id=439820 (EDIT:) which is now marked as "fixed".

Aklapper triaged this task as Low priority.Jul 16 2015, 1:45 PM
matmarex closed this task as Resolved.EditedSep 8 2015, 2:04 PM

It appears to have indeed been resolved in Chromium. I can no longer
reproduce the problem using Chromium 45.