Page MenuHomePhabricator

Incorrect prior block durations reported
Closed, ResolvedPublic

Description

On the Block User popup, the list of previous blocks (sometimes?) reports incorrect block durations. It recently reported "indefinite" and "will not expire" for all prior blocks of user 174.91.111.174. I have seen and recognized this a number of times, and have probably also seen it without having recognizing it.

Version: 3.1.12 build: 2563 3.1.12-1-ga0be145 without python support, compiled using QT 5.4.0 Running on QT 5.4.0

Event Timeline

Wtmitchell raised the priority of this task from to Needs Triage.
Wtmitchell updated the task description. (Show Details)
Wtmitchell added a subscriber: Wtmitchell.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 22 2015, 6:43 AM

Is this Huggle? You must set projects when creating tasks.

Petrb added a subscriber: Petrb.May 24 2015, 9:04 AM

YOu won a cookie for a best task number in phab :P

Petrb added a comment.May 24 2015, 3:11 PM

Can you give me example usernames where this happens? I can't reproduce it so far

Petrb added a comment.May 24 2015, 3:13 PM

you know the reason why I can't reproduce is probably that I am not sysop :D it looks that this feature is not working for normal users... need to try on test wiki then

Petrb added a comment.May 24 2015, 3:20 PM

You say it reported stuff for 174.91.111.174, can you take a screenshot? This user never was blocked and I see nothing in both huggle and mw.

I see this infrequently, only on a small percentage of the times I am trying to block a user from huggle after reporting that user who is at warning level 4, and that is not a situation I find myself in frequently in any case. I'll take screenshots the next time I see and recognize this, but I think I've reported all the info you'll glean from the screenshots. I've never attached backup like screenshots to a Phabricator report and , looking around here as I''m entering this comment, it's not obvious to me how to attach screenshots to a report while entering a comment.

Se4598 added a subscriber: Se4598.May 25 2015, 12:37 PM

I've never attached backup like screenshots to a Phabricator report and , looking around here as I''m entering this comment, it's not obvious to me how to attach screenshots to a report while entering a comment.

To add files to a comment, drag and drop them into the comment text area.

Here's some screen shots of another occurrence:

Here's Huggle showing incorrect block history information

Here's the correct information in the block log

Petrb triaged this task as High priority.Jun 15 2015, 1:25 PM

Update: I'm still seeing this with Version: 3.1.13 build: 2589 3.1.13 without python support, compiled using QT 5.4.0 Running on QT 5.4.0

Update: I am still seeing this with Version: 3.1.14 build: 2597 3.1.14 without python support, compiled using QT 5.4.0 Running on QT 5.4.0

Restricted Application added a subscriber: Luke081515. · View Herald TranscriptJul 12 2015, 6:35 AM
Legoktm set Security to None.
Petrb closed this task as Resolved.Sep 9 2015, 2:50 PM
Petrb claimed this task.

Fixed in next huggle release

Wtmitchell reopened this task as Open.Sep 15 2015, 1:51 AM

I am still seeing this with Version: 3.1.16 build: 2671 3.1.16 without python support, compiled using QT 5.4.2 Running on QT 5.4.2

Petrb closed this task as Resolved.Oct 1 2015, 8:52 PM