Page MenuHomePhabricator

False positives for Group throttle by: page
Closed, InvalidPublic

Description

Where Group throttle by(Regeln für die Gruppendrossel): is by page

Group throttle by(Regeln für die Gruppendrossel): page; The setting is by obiviously by page. Say I am user(name):ABCD and I am editing page/article named PQR . The Number of actions to allow(Anzahl erlaubter Aktionen:): is 3 and I make 4 edits on article PQR Then I go to page/article XYZ and I make only one edit on article XYZ.

In this case since on page/article XYZ only one edit and simply no other action. My experience and obsrvation is still the filter is counting and throttling this action on article XYZ. Where as as earlier said, If Group throttle by(Regeln für die Gruppendrossel): is by page I expect filter to wait until my 3 actions on page XYZ are completed, But the filter is not waiting so is this a software bug or need of edit filter software enhancement ?

For exaple please see edit filter log https://mr.wikipedia.org/wiki/विशेष:संपादनगाळणी_नोंदी/61096 and concerned user contributions on 2nd may. The given filter no 127 on mr wikipedia was supposed to trigger after 4 actions but actually it triggered on first action itself on the given article page.

I am unaware, if, bug no T100638 and this one are, techanically part of same problem or different.

Event Timeline

Mahitgar raised the priority of this task from to Needs Triage.
Mahitgar updated the task description. (Show Details)
Mahitgar added a project: AbuseFilter.
Mahitgar added subscribers: Aklapper, Mahitgar.
Mahitgar updated the task description. (Show Details)May 28 2015, 10:37 AM
Mahitgar set Security to None.
Mahitgar renamed this task from Falls positives for Group throttle by: page to False positives for Group throttle by: page .Jun 2 2015, 4:14 PM

I came across T86434 bug from nl-wikipedia where in a filter got triggered before given rate limit

Luke081515 triaged this task as Medium priority.Dec 9 2015, 8:40 AM
Daimona added a subscriber: Daimona.Apr 4 2018, 2:18 PM

Could you please rewrite the task description? Might be a problem of mine, but I can't even understand what you're talking about.

If I understand @Mahitgar correctly, the "throttle per page" setting is "3" on a wiki and after making 4 edits on the first article, one edit on a separate second article was incorrectly "counted" for the first article? (Cannot check as I do not have access for the first link given.)

@Mahitgar: In general, providing a list of steps, step by step, plus sections for expected outcome and actual outcome are welcome to make it easier for other people to reproduce problems by "just following" those steps. You can edit the task description by clicking Edit Task.

Daimona closed this task as Invalid.Oct 21 2018, 11:41 AM

I tried my best to understand the problem here, but I'm not sure I really got it. However, supposing that Andre's explanation is correct (and to me, it looks so), the behaviour is intended. If a filter is set to group throttle by page, throttle counters will be increased on a per-page basis. So, 3 edits on page XXX and 1 edit on page YYY means that the counter is 3 for XXX and 1 for YYY, and that's all. If the filter is set to take any action after e.g. 5 edits, then it'll execute such actions as soon as the higher counter reaches 5, whatever page is it for.
If, instead, the aim of this task was to report a different problem, please feel free to reopen it and provide further details, as suggested above.