Page MenuHomePhabricator

make-wmf-branch should support resuming
Closed, ResolvedPublic

Description

This has bitten me more than a couple of times and it wastes nearly an hour of my time every time it happens.

Essentially if anything goes wrong part-way through running make-wmf-branch the script retries the failed command 5 times then gives up. It is then very difficult to get the branch set up correctly as there is no way to start over and no way to resume. Very horrible experience.

The plan:

make-wmf-branch should record each step in a log of some kind. When something goes wrong we can abort, manually fix whatever was the cause, and finally re-run make-wmf-branch and use the log from the previous run to get back to where we left off.

Related Objects

StatusSubtypeAssignedTask
Resolved mmodell

Event Timeline

mmodell claimed this task.
mmodell raised the priority of this task from to Unbreak Now!.
mmodell updated the task description. (Show Details)
mmodell added a project: Deployments.
mmodell added a subscriber: mmodell.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 10 2015, 6:22 AM

I have this almost done, gonna test it today.

greg added a subscriber: greg.Jun 16 2015, 8:51 PM

How'd it go? :)

Well it went ok but there is still work to do to make-wmf-branch. Everything about this script bothers me.

mmodell lowered the priority of this task from Unbreak Now! to High.Jun 18 2015, 8:08 PM
mmodell added a subtask: Restricted Task.Jul 6 2015, 6:17 PM
csteipp closed subtask Restricted Task as Resolved.Aug 4 2015, 7:37 PM
mmodell closed this task as Resolved.Aug 19 2015, 6:48 AM

This works now locally but not on tin since tin still runs an ancient version of php.

That's fine though, I'm just running make-wmf-branch on my laptop instead of tin.

greg added a comment.Aug 19 2015, 7:07 AM

This works now locally but not on tin since tin still runs an ancient version of php.
That's fine though, I'm just running make-wmf-branch on my laptop instead of tin.

Updating the docs to reflect that:
https://wikitech.wikimedia.org/w/index.php?title=Heterogeneous_deployment%2FTrain_deploys&type=revision&diff=174215&oldid=159975

this dependency is only present in the branch named make-wmf-branch-climate