Page MenuHomePhabricator

Add a link to the Privacy Policy from the Login and Create Account screens.
Closed, ResolvedPublic

Description

This is to increase the likelihood of the user reading the privacy policy. App stores generally already link to the privacy policy, but this is giving the user another chance before entering their credentials into the Login or Create Account fields.

Details

Related Gerrit Patches:

Event Timeline

dr0ptp4kt raised the priority of this task from to Needs Triage.
dr0ptp4kt updated the task description. (Show Details)
dr0ptp4kt moved this task to Needs Triage on the Wikipedia-Android-App-Backlog board.
dr0ptp4kt added a subscriber: dr0ptp4kt.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 19 2015, 11:44 PM
Dbrant added a subscriber: Dbrant.Jun 20 2015, 1:56 AM

@dr0ptp4kt, On the Android side, we were planning on no longer displaying the splash screen (T102482), since we're not currently focusing on driving contributions and editors in the app. Would it be acceptable to display a link to the privacy policy on the Login and Create Account screens?

Looping in Vibha… I'd like her to have input on placing new buttons / links within the app before we go too far.

Like Android, killing the splash screen on launch is something we want to do on iOS as well. Slowing down the user before they can use the app is a pretty big UX anti-pattern.

However, I think we can add a link to the Privacy Policy to the login/sign up screen as @Dbrant suggests, so when user does try to create an account or log in. That is a pretty standard place to put a privacy policy and don't think would be too much of an issue.

Dbrant renamed this task from Link to the privacy policy from the splash screen the first time the app is launched to Add a link to the Privacy Policy from the Login and Create Account screens..Jun 22 2015, 5:56 PM
Dbrant updated the task description. (Show Details)
Dbrant set Security to None.
Dbrant triaged this task as Medium priority.Jun 23 2015, 2:39 AM
Dbrant moved this task from Needs Triage to Current Sprint on the Wikipedia-Android-App-Backlog board.

Change 220133 had a related patch set uploaded (by Dbrant):
Add link to privacy policy in Login and Create Account screens.

https://gerrit.wikimedia.org/r/220133

Change 220133 merged by jenkins-bot:
Add link to privacy policy in Login and Create Account screens.

https://gerrit.wikimedia.org/r/220133

Checked with 2.0.103-alpha-2015-06-25 on Samsung Tablet Ce0168(Android 4.0.4

Kindly add screenshots for mobile device.

This comment was removed by Vibhabamba.

Examined on Nexus 4, Android 5.1.1

Signed off by Design

Dbrant closed this task as Resolved.Jul 21 2015, 12:00 PM
Dbrant claimed this task.