Page MenuHomePhabricator

Hyperlinks without title disappear in flow
Closed, ResolvedPublic

Description

If you add a hyperlink in the flow post, as

[https://phabricator.wikimedia.org/maniphest/task/create/]

sometimes it just disappears and you can see nothing. The link may appear again tomorrow, and disappear again another day. You can see here an example, that does not work when I'm writing this. The problem is in the first line, just after the "ל-".
Thank you.

Details

Related Gerrit Patches:

Event Timeline

IKhitron created this task.Jul 23 2015, 2:07 PM
IKhitron raised the priority of this task from to Needs Triage.
IKhitron updated the task description. (Show Details)
IKhitron added subscribers: IKhitron, Amire80, TomerA, Matanya.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJul 23 2015, 2:07 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

And yet another example: https://he.wikipedia.org/w/index.php?title=%D7%A0%D7%95%D7%A9%D7%90:Sl2amtufzozs6xi7&topic_postId=sl725n16l4s7gzpj&topic_revId=sl725n16l4s7gzpj&action=single-view. In this case, not only that the link disappeared, it also allowed me to save an empty comment (note that the comment was later edited by [[user:IKhitron|]] in a way that made the link reappear.

I suspect the problem happens when one switches to wiki language on a page using flow.

This is because, for some reason, that link doesn't have rel="mw:Extlink" but instead has rel="nofollow"

Change 226599 had a related patch set uploaded (by Catrope):
Follow-up cf3e8e5aee: fix styling of auto-numbered external links

https://gerrit.wikimedia.org/r/226599

Change 226599 merged by jenkins-bot:
Follow-up cf3e8e5aee: fix styling of auto-numbered external links

https://gerrit.wikimedia.org/r/226599

DannyH closed this task as Resolved.Jul 29 2015, 11:24 PM
DannyH claimed this task.
DannyH triaged this task as Medium priority.
DannyH set Security to None.
TomerA reopened this task as Open.Aug 5 2015, 5:27 PM
TomerA added a comment.Aug 6 2015, 9:24 PM

Please ignore my last comment. Bug is fixed.

TomerA closed this task as Resolved.Aug 6 2015, 9:24 PM