Page MenuHomePhabricator

Create labs project for NonFreeWiki
Closed, ResolvedPublic

Description

About 18 months ago, I started a proposal for a NonFreeWiki <https://meta.wikimedia.org/wiki/NonFreeWiki > as a parallel to Wikimedia Commons. The idea is to centralise the 2.4 million unfree files that are being used in 155 content wikis, so that there is better regulation. So far 16 other people have expressed support at https://meta.wikimedia.org/w/index.php?title=NonFreeWiki/supporters&oldid=12977931
I haven't had much time to work on this until recently, but I'd like to test out the ideas in a demo wiki.

Initially:

Thank you in advance.

Event Timeline

Green_Giant raised the priority of this task from to Normal.
Green_Giant updated the task description. (Show Details)
Restricted Application added a subscriber: Steinsplitter. · View Herald TranscriptAug 6 2015, 9:48 AM
Krenair added a subscriber: Krenair.Aug 6 2015, 9:53 AM

Comment:

  1. Some extensions are not needed, like GWToolset. others includes all CentralAuth/global* extensions, CheckUser, MassMessage, OAIRepository, WikiHiero, all Wikibase extensions, CentralNotice, NewUserMessage, SecurePoll, etc. In my opinion only these extensions are needed.
  2. To prevent spam you can install OAuthAuthentication and disallow account creation by anybody. So only autoconfirmed user in Commons can register here.

You can ask zhuyifei1999 for how to configure a new Commons-like wiki

Also you need another MediaWiki installation as a client

Bugreporter renamed this task from NonFreeWiki to Create labs project for NonFreeWiki.Aug 6 2015, 2:15 PM
Bugreporter added a subscriber: bd808.
Andrew added a comment.Aug 6 2015, 2:19 PM

From the Labs terms of use:

  1. Proprietary content: Do not use or create content unless it complies with the Wikimedia Licensing policy. This includes content in the public domain or freely licensed under an applicable free culture license, such as the Creative Commons Attribution ShareAlike 3.0 license.

Would this wiki be in compliance with that requirement?

@Green_Giant So the project should only use example images for demo. It should not host any real non-free files until the site is moved to production.

Or probably create a EDP for WMFlabs?

Comment:

  1. Some extensions are not needed, like GWToolset. others includes all CentralAuth/global* extensions, CheckUser, MassMessage, OAIRepository, WikiHiero, all Wikibase extensions, CentralNotice, NewUserMessage, SecurePoll, etc. In my opinion only these extensions are needed.
  2. To prevent spam you can install OAuthAuthentication and disallow account creation by anybody. So only autoconfirmed user in Commons can register here.

Thank you for the advice. I agree with you.

Comment:

  1. Some extensions are not needed, like GWToolset. others includes all CentralAuth/global* extensions, CheckUser, MassMessage, OAIRepository, WikiHiero, all Wikibase extensions, CentralNotice, NewUserMessage, SecurePoll, etc. In my opinion only these extensions are needed.
  2. To prevent spam you can install OAuthAuthentication and disallow account creation by anybody. So only autoconfirmed user in Commons can register here.

Thank you for the advice. I agree with you.

From the Labs terms of use:

  1. Proprietary content: Do not use or create content unless it complies with the Wikimedia Licensing policy. This includes content in the public domain or freely licensed under an applicable free culture license, such as the Creative Commons Attribution ShareAlike 3.0 license.

Would this wiki be in compliance with that requirement?

Absolutely. I'm a Commons admin and I would be failing the community if I didn't adhere to this.

@Green_Giant So the project should only use example images for demo. It should not host any real non-free files until the site is moved to production.

An EDP probably wouldn't be necessary, because the aim is to demonstrate how it would work. The demo will probably use only the free goat image as done here ->https://meta.wikimedia.org/wiki/NonFreeWiki/Demo/File_page_with_no_fair_use_rationales I doubt we would need more than this, although I might be wrong.

Also you need another MediaWiki installation as a client

Correct me if I'm wrong but do you mean that we need a second wiki, to act as an example that would use the images?

Andrew closed this task as Resolved.Aug 7 2015, 6:07 PM
Andrew claimed this task.

I've created a new project, 'nonfreewiki' with green_giant as admin. You can add additional users and admins as you see fit.

Existing quotas will allow you to create two instances to host two different wikis. I'd recommend that you set up the wikis using the labs_vagrant classes; best to read this before you start: https://wikitech.wikimedia.org/wiki/Help:MediaWiki-Vagrant_in_Labs

When creating the new hosts, make sure that port 80/http is in a security group that's applied to the new hosts. Then you can use the labs web proxy system to provide https access for the outside world.

I've created a new project, 'nonfreewiki' with green_giant as admin. You can add additional users and admins as you see fit.
Existing quotas will allow you to create two instances to host two different wikis. I'd recommend that you set up the wikis using the labs_vagrant classes; best to read this before you start: https://wikitech.wikimedia.org/wiki/Help:MediaWiki-Vagrant_in_Labs
When creating the new hosts, make sure that port 80/http is in a security group that's applied to the new hosts. Then you can use the labs web proxy system to provide https access for the outside world.

Please excuse my ignorance, but where is this project and where do I start? I've read the help page and I am stuck at the first section.

scfc added a comment.Aug 9 2015, 6:04 PM

Have you followed the link Create your instance there?

Yes I've gone through the steps (although they are confusingly laid out). Specifically I've got shell access, logged in at wikitech and gerrit, and uploaded an ssh key to both. What I don't understand is where exactly to find the project. I'm stuck at the point on https://wikitech.wikimedia.org/wiki/Help:Getting_Started#Access_Project_Instances. It isn't clear where I have to enter:

ssh <instancename>.eqiad.wmflabs

I've tried it with git bash, entering both bastion.eqiad.wmflabs and nonfreewiki.eqiad.wmflabs. Both give a similar reply:

ssh: Could not resolve hostname bastion.eqiad.wmflabs: no address associated with name

scfc added a comment.Aug 9 2015, 11:28 PM

Your project's page is https://wikitech.wikimedia.org/wiki/Nova_Resource:Nonfreewiki. You don't have any instances yet. To change that, go to Manage Instances, select your project in the "Project filter" and click "Add instance" in the section for your project. Your instance will then be available as nameyouchoseforyourinstance.eqiad.wmflabs.

To ssh to your instance (after you created it plus a few minutes), you need to set up your local machine to access first a bastion instance and then connect from that to your instance. This is described by "Accessing instances with ProxyCommand ssh option (recommended)".

When you have set up your local machine correctly, you should be able to:

  • ssh bastion.wmflabs.org and get a prompt with your shell user name in front, and
  • ssh nameyouchoseforyourinstance.eqiad.wmflabs and be logged in on your instance.

In the Manage Instances box, the only one available is Bastion. When I try to connect to bastion I still receive the same error message.

In Accessing instances with ProxyCommand ssh option (recommended), what exactly is "~/.ssh/config" and the "local machine"?

scfc reopened this task as Open.Aug 10 2015, 1:45 AM

Ha. https://wikitech.wikimedia.org/wiki/Nova_Resource:Nonfreewiki says members are @Andrew and novaadmin. @Andrew, I think you forgot to add @Green_Giant to the project.

@Green_Giant: ~/.ssh/config is the file config in the subdirectory .ssh of your home directory on your computer. If you don't use Linux or something similar, there is for example Help:Putty for Putty on Windows.

Steinsplitter added a comment.EditedAug 10 2015, 10:54 AM

Since this is only a wiki for small tests (?) i would suggest to set up only a simply wiki installation (without difficult caching systems like varnish). And it does not need oauth and other stuff to prevent spam, a simple captcha is enough.

oops, yeah, username is green-giant. Apparently wikitech doesn't notify me if I request an invalid member when creating a project.

@Green_Giant, you should be able to select your project in the project filter now.

Ahh. Thank you very much, it now makes sense.

Green_Giant closed this task as Resolved.Aug 10 2015, 1:48 PM