Allow user to create new board at Special:EnableFlow without description
Closed, ResolvedPublic

Description

Add a corresponding browser test.

Mattflaschen-WMF updated the task description. (Show Details)
Mattflaschen-WMF raised the priority of this task from to Unbreak Now!.
Mattflaschen-WMF added a subscriber: Mattflaschen-WMF.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptAug 7 2015, 5:20 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 230368 had a related patch set uploaded (by Mattflaschen):
Show friendly error if no description on EnableFlow fresh creation

https://gerrit.wikimedia.org/r/230368

What do you think about making the description optional?

What do you think about making the description optional?

With our current data model, for the board to exist we must have some entity (either description or topic). If we made it optional, we would have to auto-generate a description. That would be fine, just would need confirmation and text from @DannyH.

Sorry, I need to back up a step. :) I've been creating boards without a topic or description so far, and it's looked okay so far. What does making the description optional mean?

Change 230368 merged by jenkins-bot:
Show friendly error if no description on EnableFlow fresh creation

https://gerrit.wikimedia.org/r/230368

Sorry, I need to back up a step. :) I've been creating boards without a topic or description so far, and it's looked okay so far. What does making the description optional mean?

Are you sure those weren't already existing pages (where the old content got automatically archived)?

This task only applies to pages that are previously non-existent.

I just created a board at a brand new page on beta:
http://en.wikipedia.beta.wmflabs.org/wiki/Talk:Terwilliger

Looking at the history, it's showing that I created a zero-character board description:
http://en.wikipedia.beta.wmflabs.org/w/index.php?title=Talk:Terwilliger&action=history

Is that a problem? It seems reasonable to me.

I just created a board at a brand new page on beta:
http://en.wikipedia.beta.wmflabs.org/wiki/Talk:Terwilliger

Also, the task only affects wikis with External Store currently (although arguably it should also not allow empty content for non-External Store I'm not going to spend time on it right now since that doesn't affect production).

Production uses External Store. Beta does not currently (T95871). It should, so we don't have these discrepancies.

What do you think about making the description optional?

If we want to do this, let's create a separate task.

This can only be QA-ed in production, or locally with External Store (but this is still under review, see https://gerrit.wikimedia.org/r/#/c/223724/ ).

@Etonkovidova I recommend you ask for flow-create-board rights on https://test.wikipedia.org/ . That should let you reproduce the bug now, and the fix when it rolls out tomorrow.

Checked on https://test.wikipedia.org/wiki/Special:EnableFlow. The following error message is there:

"flow-special-enableflow-non-existent-requires-description": "To create a Flow board where no page currently exists, you must provide a description."

Moving this back to In Development, @Mattflaschen and @SBisson are working on allowing boards to be created with a blank description.

Mattflaschen-WMF lowered the priority of this task from Unbreak Now! to Needs Triage.Aug 20 2015, 8:59 PM

This is not an unbreak now anymore, though, since the user is no longer potentially shown an exception.

Mattflaschen-WMF triaged this task as Normal priority.Aug 20 2015, 8:59 PM
DannyH set Security to None.
Mattflaschen-WMF renamed this task from "Must have data to write to external storage" when using Special:EnableFlow on non-existent page with header field empty to Allow user to create new board at Special:EnableFlow without description.Aug 21 2015, 5:49 PM
Mattflaschen-WMF removed Mattflaschen-WMF as the assignee of this task.
Mattflaschen-WMF updated the task description. (Show Details)

The patch will allow all content to be zero-length with external store, so even if the user input is still zero length after processing, it will be fine.

Standard wikitext pages can already be zero-length, and External Store can handle this.

We could consider allowing this in other places (e.g. zero-length posts), but there's no need to do this. As is, there are higher-level checks to prevent this for most types of content other than description and summary.

Change 234575 had a related patch set uploaded (by Mattflaschen):
Allow zero-length descriptions in both S:EF and standard edits

https://gerrit.wikimedia.org/r/234575

Change 234575 merged by jenkins-bot:
Allow zero-length descriptions in both S:EF and standard edits

https://gerrit.wikimedia.org/r/234575

Etonkovidova added a comment.EditedSep 1 2015, 5:32 PM

Checked in betalabs:

  • the warning is not displayed and the board can be created without a description
DannyH closed this task as Resolved.Sep 2 2015, 10:45 PM

Beautiful, thank you!