[Bug] Text field doesn't always load when trying to add a statement
Closed, ResolvedPublic

Description

Sometimes when trying to add a statement, the text input field doesn't appear, there's just a loading spinner which never goes away. This was also reported at https://www.wikidata.org/wiki/Wikidata:Contact_the_development_team#Problems_with_Safari_using_present_in_work_.28P1441.29

I've never been able to reproduce it reliably, but it happens to me when I select a property and the text field for the value doesn't appear fast enough - I start typing and it goes into the property input field instead, which triggers another search (removing the text field for the value), then when I delete the text I typed and try to select the same property again, the text field won't load.

I have however come across another way to trigger it which is reproducible (for me in Chromium and Firefox, at least):

  • Load https://test.wikidata.org/wiki/Q778
  • Click the "add" link to add a new statement
  • Type "country" into the property search
  • Let it finish loading - it will display a text input field and move the focus into it
  • Click "country calling code"

Instead of loading a text field as expected, it just displays a spinner which never goes away.

Nikki created this task.Oct 12 2015, 4:21 PM
Nikki updated the task description. (Show Details)
Nikki raised the priority of this task from to Needs Triage.
Nikki added a project: Wikidata.
Nikki added a subscriber: Nikki.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 12 2015, 4:21 PM
Lydia_Pintscher renamed this task from Text field doesn't always load when trying to add a statement to [Bug] Text field doesn't always load when trying to add a statement.Oct 14 2015, 2:48 PM
Lydia_Pintscher set Security to None.
Lydia_Pintscher triaged this task as Normal priority.
Lydia_Pintscher added a subscriber: Lydia_Pintscher.
abian awarded a token.Aug 21 2016, 9:37 AM
abian added a subscriber: abian.EditedAug 21 2016, 10:06 AM

The following issue can be faithfully reproduced by now for any item.

Scope

  • uselang: Spanish (es)
  • page: any Wikidata item (no matter which one)

Steps

  1. Click on "add reference" (no matter if it's for an existing statement or for a statement that you're creating).
  2. Write "url". "dirección web (URL)" (P854) will be shown as the second suggestion.
  3. Click on "dirección web (URL)". The text field for writing the value will never appear.

Alternative steps

  • On 2, write "dirección web" instead of "url" and, then, click on "dirección web". The text field will appear as expected.
hoo added a subscriber: hoo.Aug 21 2016, 1:44 PM
hoo added a comment.Aug 22 2016, 4:43 PM

I was able to reproduce this using Epiphany.

Change 306136 had a related patch set uploaded (by Hoo man):
Always destroy Variation in snakview if property id changes

https://gerrit.wikimedia.org/r/306136

hoo claimed this task.Aug 23 2016, 3:11 AM
hoo moved this task from Proposed to Review on the Wikidata-Sprint-2016-08-16 board.

Change 306136 merged by jenkins-bot:
Always destroy Variation in snakview if property id changes

https://gerrit.wikimedia.org/r/306136

hoo closed this task as Resolved.Aug 24 2016, 5:48 PM
hoo moved this task from Review to Done on the Wikidata-Sprint-2016-08-16 board.
hoo removed a project: Patch-For-Review.

I'm still running into this, sadly. :(

Nikki added a comment.Dec 8 2016, 6:08 PM

The method I mentioned in the description seems to be fixed, but I've found another way I can reproduce it fairly reliably:

  • Load https://test.wikidata.org/wiki/Q778 again
  • Click the "add" link to add a new statement
  • Type "instance o" into the property search
  • Before typing the "f", get your hand ready to press backspace
  • Press "f" and it will start to show a text field - the moment the spinner shows up on the right, press backspace
  • Press "f" again and it will start to show a text field again, but instead you will get a spinner that never goes away

If you're not fast enough to backspace before the text field loads, refresh the page and try again.

In Chromium I get the error:

VM19605:641 Uncaught TypeError: Cannot read property 'wrapInner' of null

and from Firefox:

TypeError: this.$viewPort is null load.php:851:0

Nikki reopened this task as Open.Dec 11 2016, 12:17 PM

I'm reopening this since the problem isn't completely resolved (see above). :(

I have noticed that if I check the console after accidentally triggering this problem while editing, it shows the same error I mentioned in my previous comment.

Change 326412 had a related patch set uploaded (by Thiemo Mättig (WMDE)):
Add missing check to API response code in snakview.variations.Value

https://gerrit.wikimedia.org/r/326412

Change 326412 merged by jenkins-bot:
Add missing check to API response code in snakview.variations.Value

https://gerrit.wikimedia.org/r/326412

thiemowmde moved this task from Proposed to Done on the Wikidata-Sprint board.
thiemowmde closed this task as Resolved.