Page MenuHomePhabricator

[CatWatch] Category namespace prefix is trimmed from RC links
Closed, ResolvedPublic

Description

First observed on es.wiktionary during the August release of CatWatch, but I hadn't the time to confirm this properly. We have several categories of the form Categoría:Wikcionario:xx, which translates to the canonical names Category:Project:xx. It must be noted that the category's title starts from the second member (Wikcionario:xx); however, CatWatch would skip the Category: part and treat Project: (or whatever alias is used) as the new namespace prefix.

This has been reproduced on test.wikipedia:

  1. Create Category:Project:CatWatchTest
  2. Add a link to this category somewhere: edit
  3. Take a look at the RC:
16:46 	Wikipedia:CatWatchTest‎ . . (0)‎ . . Peter Bowman (talk | contribs) (User:Peter Bowman/misc added to category) (diff | hist)

The Project: bit was resolved to Wikipedia: and the RC link points now to an incorrect title: [[Wikipedia:CatWatchTest]].

Event Timeline

PeterBowman raised the priority of this task from to Needs Triage.
PeterBowman updated the task description. (Show Details)
PeterBowman added a subscriber: PeterBowman.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptNov 27 2015, 4:15 PM

I have just noted that there are no logs of page additions/deletions to said category on my watchlist, not sure why. Other categories are shown there as expected.

Change 255722 had a related patch set uploaded (by Umherirrender):
Fix categories with a namespace prefix in the cat name for CatWatch

https://gerrit.wikimedia.org/r/255722

Due to a wrong use of Title::newFromText the recent change entry was created with the wrong name, so your watchlist cannot found the cat addition. Maybe you can see the entries when having the Wikcionario:xx page on your watchlist. The wrong rows will be deleted automatically 30 days after the fix is on your wiki.

You are right, I watched [[Wikipedia:CatWatchTest]] and then it showed up on my watchlist (CatWatch is currently enabled on test WMF wikis, we'll have to wait for its arrival on eswikt). Thanks for investigating this issue :).

Change 255722 merged by jenkins-bot:
Fix categories with a namespace prefix in the cat name for CatWatch

https://gerrit.wikimedia.org/r/255722

Addshore closed this task as Resolved.Dec 4 2015, 11:14 AM
Tobi_WMDE_SW moved this task from Incoming to CatWatch on the TCB-Team board.Nov 22 2016, 11:18 AM