Page MenuHomePhabricator

[Regression pre-wmf.10] ResourceLoaderFileModule: script file not found: "extensions/Graph/includes/modules/ve-graph/ve.ce.MWGraphNode.js"
Closed, ResolvedPublic1 Story Points

Description

Cannot open VE for any page in Beta Cluster , getting this error in the console log:
"VisualEditor failed to load: Error: Module ext.graph.visualEditor has failed dependencies"

Event Timeline

Ryasmeen created this task.Jan 4 2016, 10:25 PM
Ryasmeen updated the task description. (Show Details)
Ryasmeen raised the priority of this task from to Needs Triage.
Ryasmeen added a project: VisualEditor.
Ryasmeen added a subscriber: Ryasmeen.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptJan 4 2016, 10:25 PM
Ryasmeen renamed this task from VE not loading in Beta cluster, shows error "VisualEditor failed to load: Error: Module ext.graph.visualEditor has failed dependencies" to [Regression pre-wmf.10] VE not loading in Beta cluster, shows error "VisualEditor failed to load: Error: Module ext.graph.visualEditor has failed dependencies".Jan 5 2016, 5:26 AM
Ryasmeen set Security to None.
Ryasmeen added a subscriber: Yurik.

Change 262424 had a related patch set uploaded (by Yurik):
Fixed broken modules path

https://gerrit.wikimedia.org/r/262424

The error I am getting now is:
[3b3eac65] /w/load.php?debug=false&lang=en&modules=ext.centralauth.ForeignApi%7Cext.cite.style%7Cext.citoid.visualEditor%7Cext.citoid.visualEditor.data%7Cext.disambiguator.visualEditor%7Cext.geshi.visualEditor%7Cext.graph.visualEditor%7Cext.math.visualEditor%7Cext.score.visualEditor%7Cext.visualEditor.base%2Ccore%2Cdata%2CdesktopArticleTarget%2Cexperimental%2Cicons%2Clanguage%2Cmediawiki%2Cmwalienextension%2Cmwcore%2Cmwformatting%2Cmwgallery%2Cmwimage%2Cmwlink%2Cmwmeta%2Cmwreference%2Cmwsignature%2Cmwtransclusion%2Cswitching%7Cext.visualEditor.core.desktop%7Cext.visualEditor.mwimage.core%7Cext.visualEditor.mwreference.core%7Cext.visualEditor.mwtransclusion.core%7Cext.wikihiero.visualEditor%7Cjquery.autoEllipsis%2CbyteLimit%7Cjquery.uls.data%7Cmediawiki.ForeignApi%2CForeignStructuredUpload%2CForeignUpload%2CUpload%2Cwidgets%7Cmediawiki.ForeignApi.core%7Cmediawiki.ForeignStructuredUpload.BookletLayout%7Cmediawiki.Upload.BookletLayout%7Cmediawiki.action.history.diff%7Cmediawiki.api.edit%2Cupload%7Cmediawiki.language.names%2CspecialCharacters%7Cmediawiki.libs.jpegmeta%7Cmediawiki.page.gallery.styles%7Cmediawiki.skinning.content.parsoid%7Cmediawiki.widgets.CategorySelector%2CDateInputWidget%2Cstyles%7Coojs-ui%2Cpapaparse%2Crangefix%2Cunicodejs%7Coojs-ui.styles%7Coojs-ui.styles.icons%2Cicons-alerts%2Cicons-editing-advanced%2Cicons-editing-core%2Cicons-editing-list%2Cicons-editing-styling%2Cicons-interactions%2Cicons-media%2Cindicators%2Ctextures&skin=vector&version=76663ede4ca3 MWException from line 809 of /srv/mediawiki/php-master/includes/resourceloader/ResourceLoaderFileModule.php: ResourceLoaderFileModule::readScriptFiles: script file not found: "/srv/mediawiki/php-master/extensions/Graph/includes/modules/ve-graph/ve.ce.MWGraphNode.js"

Ryasmeen renamed this task from [Regression pre-wmf.10] VE not loading in Beta cluster, shows error "VisualEditor failed to load: Error: Module ext.graph.visualEditor has failed dependencies" to [Regression pre-wmf.10] VE not loading in Beta cluster, shows error in the console.Jan 5 2016, 6:13 AM

Change 262424 merged by jenkins-bot:
Fixed broken modules path

https://gerrit.wikimedia.org/r/262424

Krinkle renamed this task from [Regression pre-wmf.10] VE not loading in Beta cluster, shows error in the console to [Regression pre-wmf.10] ResourceLoaderFileModule: script file not found: "extensions/Graph/includes/modules/ve-graph/ve.ce.MWGraphNode.js".
Krinkle triaged this task as Unbreak Now! priority.
Krinkle added a project: Regression.
Krinkle closed this task as Resolved.
Krinkle claimed this task.
Jdforrester-WMF edited a custom field.