Page MenuHomePhabricator

Support external link templates
Open, Needs TriagePublic0 Story Points

Description

Citoid provides an easy and quick way to cite source, but it lacks the ability to use specific templates based on sources rather than generic templates for sources types.

One of the most popular ways to cite sources that are commonly used is using external links templates such as https://en.wikipedia.org/wiki/Category:External_link_templates (other wikis have similar templates). External links templates give editors the flexibility to update wiki-wide the URLs for a site, if it change its URL structure.

It would be awsome if it would be possible to do it using Citoid-template-type-map.json, by declaring

"blogPost": "Cite blog",
"blogPost[url^=http://blog.wikimedia.org]": "Cite Wikimedia blog",

(or some other way) to use site specific (or in more general source specific) template

Event Timeline

eranroz created this task.Feb 8 2016, 6:18 PM
eranroz updated the task description. (Show Details)
eranroz raised the priority of this task from to Needs Triage.
eranroz added a project: Citoid.
eranroz added a subscriber: eranroz.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 8 2016, 6:18 PM
Johsthao closed this task as a duplicate of T126250: <spam>.Feb 8 2016, 6:24 PM
matmarex reopened this task as Open.Feb 8 2016, 6:32 PM
Mvolz moved this task from Backlog to Zotero on the Citoid board.Oct 28 2016, 3:21 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptOct 28 2016, 3:21 PM
Mvolz moved this task from Zotero to Extension on the Citoid board.Oct 28 2016, 3:22 PM
Jdforrester-WMF set the point value for this task to 0.Feb 9 2017, 6:20 PM