Page MenuHomePhabricator

Unable to add statement with math or external identifier data type
Closed, ResolvedPublic

Description

when adding a statement with math data type (e.g. "defining formula"), I sometimes get an error about the property being deleted.

"It is not possible to define a new value for a deleted property."

for me, this happens only in Firefox in non-debug mode, but it happens for other people in other browsers and sometimes when logged in.

Event Timeline

aude created this task.Feb 16 2016, 5:53 PM
aude raised the priority of this task from to High.
aude updated the task description. (Show Details)
aude added a project: Wikidata.
aude added a subscriber: aude.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 16 2016, 5:53 PM
aude added a comment.Feb 16 2016, 5:54 PM

when looking at api requests done, the property is found.

relevant code that produces the error is in snakview.variations.Value.js (message "wikibase-snakview-variation-nonewvaluefordeletedproperty")

Happens to me on Chrome and Safari, both logged in and out.

aude added a comment.Feb 16 2016, 6:03 PM

when i have this issue, wikibase.dataTypeStore is missing math and external-id

when it works, these are present

Mentioned in SAL [2016-02-16T18:06:10Z] <aude@tin> Synchronized php-1.27.0-wmf.13/extensions/Wikidata/extensions/Wikibase/repo/resources/dataTypes/wikibase.dataTypeStore.js: Try to fix T127095 (duration: 00m 57s)

aude added a comment.Feb 16 2016, 6:17 PM

think the problem (pretty obvious now) is https://github.com/wmde/DataTypes/blob/master/src/Modules/DataTypesModule.php which is probably needs to override ResourceLoaderModule::getDefinitionSummary

aude added a comment.Feb 16 2016, 7:10 PM

I am working on a fix in https://github.com/wmde/DataTypes/pull/50 (working now on tests for this)

also discovered the DataTypesModuleTest is broken on master, and the tests are never run by travis nor by jenkins when testing the build. So I need to fix that, as well.

aude claimed this task.Feb 16 2016, 7:11 PM
aude set Security to None.

This might be a duplicate of T123398. Can someone check?

Yes it is the same issue. It has not been fixed.

Bugreporter renamed this task from Unable to add statement with math data type to Unable to add statement with math or external identifier data type.Feb 17 2016, 7:31 AM

https://gerrit.wikimedia.org/r/#/c/271242/ should help debugging such changes in the future.

Mentioned in SAL [2016-02-17T15:53:58Z] <aude@tin> Synchronized php-1.27.0-wmf.13/extensions/Wikidata: Fix caching data types bug: T127095 (duration: 01m 44s)

aude added a comment.Feb 17 2016, 4:01 PM

I think this is fixed. I can now add external id and math properties in Firefox.

aude closed this task as Resolved.Feb 17 2016, 4:02 PM
aude moved this task from Review to Done on the Wikidata-Sprint-2016-02-16 board.