Page MenuHomePhabricator

SVG-Fallback of MathML does not show umlauts in Safari 9.0.3
Closed, ResolvedPublic

Description

Hello,

one of the authors in the project https://de.wikibooks.org/wiki/Mathe_f%C3%BCr_Nicht-Freaks reported a bug when he views the article https://de.wikibooks.org/wiki/Mathe_f%C3%BCr_Nicht-Freaks:_Komposition_stetiger_Funktionen#Motivation with the new MathML mode. He uses Safari version 9.0.3 (11601.4.4) so that he sees the SVG fallback. The umlauts in the formula are not shown as you can see in the following screenshot made by him

However, I cannot reproduce the problem with my Chromium 49.0.2623.87 on Ubuntu 15.10. I get

Related Objects

Event Timeline

Kulla created this task.Mar 25 2016, 10:34 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 25 2016, 10:34 PM
Pkra added a subscriber: Pkra.Mar 30 2016, 7:48 AM

This seems to be a browser bug. I can reproduce the problem on a different WebKit-based brower (WebKit 2.8.5) but the SVG itself renders fine in that browser.
@Kulla can the user check if, e.g., https://de.wikibooks.org/api/rest_v1/media/math/render/svg/3ae834eb3ea9ab94a47e25a450acd13f7df1690c, shows the Umlaut?

This issue has shown up before for Chrome (but I can't find the issue number) and is probably related to text elements in SVGs when used as background-images.

Kulla added a comment.Mar 30 2016, 4:49 PM

Yes, viewing only the svg he can see the umlaut.

Pkra added a comment.Nov 30 2018, 5:00 PM

This seems to have finally been fixed upstream, cf. https://bugs.webkit.org/show_bug.cgi?id=191834

Pkra added a comment.Dec 6 2018, 4:40 PM

I'm not sure what the closing policy is here. Do we have to wait until the next Safari is released before closing this?

Pkra moved this task from Incoming to Doing on the Math board.Dec 7 2018, 10:56 AM
Kulla added a comment.Dec 8 2018, 8:15 PM

@Pkra Am I right that T50032 already track this issue. If so, this issue can also be closed as a duplicate...

Pkra added a comment.Dec 9 2018, 9:23 PM

@Kulla I think (though I may be wrong) that T50032 is a broader tracking issue that covers various input and output issues around complex scripts.

TheDJ closed this task as Resolved.Dec 10 2018, 10:41 AM
TheDJ claimed this task.
TheDJ edited projects, added Upstream; removed Mathoid.
TheDJ added a subscriber: TheDJ.

This issue is a known problem with older versions of Google Chrome and Versions of Webkit up to version 12. It is suspected this will be fixed in Safari 12.1 (eta march 2019).
As the upstream browser problem has been fixed, we are closing this ticket, as there is nothing further we can do from our side.