Page MenuHomePhabricator

[Regression pre-wmf.22] Double check mark appearing next to "Heading" and "Page Title"
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Go to Page title option from the menu

2.Select Heading/Page Title
Observe that, two tick marks appearing next to the option, also its not automatically enabling cursor on that line

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 20 2016, 10:49 PM

Caused by https://gerrit.wikimedia.org/r/#/c/283182/ - MenuToolGroup doesn't set the icon by JS so it never gets the 'oo-ui-iconElement' class.

Esanders assigned this task to matmarex.Apr 21 2016, 9:10 AM
Esanders triaged this task as High priority.
Esanders added a project: OOUI.

I feel like we've broken this at least once in the past… The issue is not apparent in OOjs UI demo, because the menu item there does have an icon, and so 'oo-ui-iconElement' class too.

Change 284728 had a related patch set uploaded (by Bartosz Dziewoński):
Correct styles for MenuToolGroup checkmarks

https://gerrit.wikimedia.org/r/284728

Change 284733 had a related patch set uploaded (by Jforrester):
OOjs UI: Correct display of MenuToolGroup checkmarks

https://gerrit.wikimedia.org/r/284733

Change 284728 merged by jenkins-bot:
Correct styles for MenuToolGroup checkmarks

https://gerrit.wikimedia.org/r/284728

Jdforrester-WMF closed this task as Resolved.Apr 21 2016, 5:52 PM
Jdforrester-WMF moved this task from Backlog to OOjs-UI-0.17.0 on the OOUI board.
Jdforrester-WMF edited projects, added OOUI (OOjs-UI-0.17.0); removed OOUI.
Jdforrester-WMF set the point value for this task to 1.

Change 284733 merged by jenkins-bot:
OOjs UI: Correct display of MenuToolGroup checkmarks

https://gerrit.wikimedia.org/r/284733

Changing the summary, the cursor issue is probably related with https://phabricator.wikimedia.org/T133229

Ryasmeen renamed this task from [Regression pre-wmf.22] Double check mark appearing next to "Heading" and "Page Title", also cursor is not appearing on that line automatically to [Regression pre-wmf.22] Double check mark appearing next to "Heading" and "Page Title".Apr 21 2016, 6:53 PM