Page MenuHomePhabricator

[Regression] srcset sometimes stripped on desktop/vector page views
Closed, ResolvedPublic1 Estimated Story Points

Description

Until I purged it, https://en.wikipedia.org/wiki/Erik_Möller didn't have a HiDPI srcset enabled for the infobox image.

The view happened in Chrome from the United Kingdom, on en.wikipedia.org, and logged-in.

<img alt="Moeller, Erik November 2014.jpg" src="//upload.wikimedia.org/wikipedia/commons/thumb/d/dd/Moeller%2C_Erik_November_2014.jpg/220px-Moeller%2C_Erik_November_2014.jpg" width="220" height="147" data-file-width="1800" data-file-height="1200">


<!-- 
NewPP limit report
Parsed by mw1115
Cached time: 20160516214909
Cache expiry: 86400
Dynamic content: true
CPU time usage: 0.840 seconds
Real time usage: 1.167 seconds
Preprocessor visited node count: 3150/1000000
Preprocessor generated node count: 0/1500000
Post‐expand include size: 99083/2097152 bytes
Template argument size: 1729/2097152 bytes
Highest expansion depth: 11/40
Expensive parser function count: 4/500
Lua time usage: 0.437/10.000 seconds
Lua memory usage: 4.77 MB/50 MB
Number of Wikibase entities loaded: 1-->
<!-- 
Transclusion expansion time report (%,ms,calls,template)
100.00%  825.087      1 - -total
 53.96%  445.258      1 - Template:Reflist
 36.95%  304.867     36 - Template:Cite_web
 13.19%  108.839      1 - Template:Infobox_person
  8.08%   66.629      1 - Template:Infobox
  4.98%   41.084      2 - Template:Category_handler
  4.54%   37.439      1 - Template:Lang
  4.20%   34.659      1 - Template:Better_source
  4.01%   33.096      5 - Template:Cite_book
  3.53%   29.103      3 - Template:Navbox
-->
<!-- Saved in parser cache with key enwiki:pcache:idhash:17886008-0!*!0!!en!4!* and timestamp 20160516214908 and revision id 714482840
 -->

.. mw.config.set({"wgBackendResponseTime":140,"wgHostname":"mw1236"});});

..

Looks like this was recently inserted in the parser cache (yesterday).

Event Timeline

Krinkle created this task.May 17 2016, 8:28 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 17 2016, 8:28 PM
Krinkle updated the task description. (Show Details)May 17 2016, 8:29 PM

After purging:

<img alt="Moeller, Erik November 2014.jpg" src="//upload.wikimedia.org/wikipedia/commons/thumb/d/dd/Moeller%2C_Erik_November_2014.jpg/220px-Moeller%2C_Erik_November_2014.jpg" width="220" height="147" srcset="//upload.wikimedia.org/wikipedia/commons/thumb/d/dd/Moeller%2C_Erik_November_2014.jpg/330px-Moeller%2C_Erik_November_2014.jpg 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/d/dd/Moeller%2C_Erik_November_2014.jpg/440px-Moeller%2C_Erik_November_2014.jpg 2x" data-file-width="1800" data-file-height="1200">

..

<!-- 
NewPP limit report
Parsed by mw1094
Cached time: 20160517202431
Cache expiry: 86400
Dynamic content: true
CPU time usage: 0.763 seconds
Real time usage: 0.948 seconds
Preprocessor visited node count: 3150/1000000
Preprocessor generated node count: 0/1500000
Post‐expand include size: 99083/2097152 bytes
Template argument size: 1729/2097152 bytes
Highest expansion depth: 11/40
Expensive parser function count: 4/500
Lua time usage: 0.401/10.000 seconds
Lua memory usage: 4.77 MB/50 MB
Number of Wikibase entities loaded: 1-->
<!-- 
Transclusion expansion time report (%,ms,calls,template)
100.00%  838.450      1 - -total
 47.37%  397.172      1 - Template:Reflist
 32.42%  271.835     36 - Template:Cite_web
 18.41%  154.319      1 - Template:Infobox_person
  8.16%   68.390      1 - Template:Wikidata_image
  7.70%   64.523      1 - Template:Infobox
  5.23%   43.858      1 - Template:Commons_category
  4.43%   37.162      2 - Template:Category_handler
  4.05%   33.957      1 - Template:Lang
  4.00%   33.501      1 - Template:Better_source
-->
<!-- Saved in parser cache with key enwiki:pcache:idhash:17886008-0!*!0!!en!4!* and timestamp 20160517202430 and revision id 714482840
 -->

.. mw.config.set({"wgBackendResponseTime":148,"wgHostname":"mw1180"});});

..

Change 287794 had a related patch set uploaded (by Jdlrobson):
Add parser cache hash key for $wgMFStripResponsiveImages state

https://gerrit.wikimedia.org/r/287794

Jhernandez triaged this task as Unbreak Now! priority.Jun 1 2016, 4:08 PM
Restricted Application added subscribers: Luke081515, TerraCodes, Urbanecm. · View Herald TranscriptJun 1 2016, 4:08 PM
Jdlrobson set the point value for this task to 1.Jun 1 2016, 4:08 PM

Change 287794 merged by jenkins-bot:
Add parser cache hash key for $wgMFStripResponsiveImages state

https://gerrit.wikimedia.org/r/287794

Jdlrobson closed this task as Resolved.Jun 1 2016, 6:13 PM
Jdlrobson claimed this task.
Jdlrobson added a subscriber: Jdlrobson.

We should reopen if we see any more examples of this post deployment.