Page MenuHomePhabricator

After switching from VE to wikitext, you're warned about the summary being missing even if you have one (because it's the same as it starts with)
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  1. Enable "Prompt me when entering a blank edit summary" in your preferences
  2. Start editing a page in VE, add an edit summary
  3. Switch to the wikitext editor
  4. Try to save

Expected result:
Page saves without warning.

Actual result:
A warning about a missing edit summary is shown, though it is present.

Event Timeline

Schnark created this task.May 23 2016, 9:39 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 23 2016, 9:39 AM
Jdforrester-WMF renamed this task from After switching from VE to wikitext, wrong warning about missing summary is shown to After switching from VE to wikitext, you're warned about the summary being missing even if you have one (because it's the same as it starts with).May 24 2016, 7:32 PM
Jdforrester-WMF triaged this task as Low priority.
Jdforrester-WMF set the point value for this task to 1.

Change 294526 had a related patch set uploaded (by Alex Monk):
Set an automatic summary of empty string when switching from VE into WTE

https://gerrit.wikimedia.org/r/294526

Change 294526 merged by jenkins-bot:
Set an automatic summary of empty string when switching from VE into WTE

https://gerrit.wikimedia.org/r/294526

Jdforrester-WMF closed this task as Resolved.Jun 29 2016, 4:17 PM
Jdforrester-WMF removed a project: Patch-For-Review.