Page MenuHomePhabricator

Prompt for edit summary: When you switch from VisualEditor to the wikitext editor, it can't see your edit summary
Closed, ResolvedPublic1 Story Points

Description

In her original words:

I was in VE and had already added an edit summary when I switched to source editor... When I saved in the source editor, I could see my VE edit summary in the source edit summary box. Good! But the save failed, saying I hadn't provided an edit summary (I have that preference set). It would be nice if it realised that I had provided an edit summary.

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterKeep edit summary when switching between VE and NWE

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 7 2016, 9:25 AM
Jdforrester-WMF changed the task status from Open to Stalled.Sep 7 2016, 7:00 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Yeah, this is working fine for me in Chrome and Firefox on master. What browsers were they using and when did this happen? If it was back in June, or somehow with a really old cached version of code, it probably is now fixed?

Schnark changed the task status from Stalled to Open.Sep 8 2016, 9:29 AM

I can reproduce that the issue still/again exists:

-> A warning about a missing summary was shown, I had to save a second time. (https://de.wikipedia.org/w/index.php?title=Sprachsynthese&diff=157757477&oldid=155521692)

Browser is Firefox 46.0.1 on Ubuntu.

The report was on 20 August 2016. I believe that this editor is usually (but not always) running the lastest version of Chrome on Windows 8.1.

Jdforrester-WMF triaged this task as Medium priority.Oct 31 2016, 3:42 PM
Jdforrester-WMF set the point value for this task to 1.

Works for me if I disable NWE

Change 318960 had a related patch set uploaded (by Alex Monk):
Keep edit summary when switching between VE and NWE

https://gerrit.wikimedia.org/r/318960

Change 318960 merged by jenkins-bot:
Keep edit summary when switching between VE and NWE

https://gerrit.wikimedia.org/r/318960

Jdforrester-WMF closed this task as Resolved.Nov 2 2016, 10:47 PM
Jdforrester-WMF assigned this task to AlexMonk-WMF.