Page MenuHomePhabricator

Toolbar for editing should be in a fixed position and not move around
Closed, ResolvedPublic

Description

Given that I open an article for translation
When I do something that triggers a warning
Then the edit toolbar moves to a new location

It is very confusing to try to track down where the toolbar is, it would be much better if it stayed in a single position.


Note that in the second screendump there is a warning and the toolbar has moved.

Event Timeline

jeblad created this task.Jun 8 2016, 8:21 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptJun 8 2016, 8:21 PM
Amire80 triaged this task as Normal priority.Jun 19 2016, 9:03 PM
Amire80 added a project: WorkType-Maintenance.
Amire80 added subscribers: Pginer-WMF, Amire80.

Nice catch!

Double-checking with @Pginer-WMF—it's supposed to be always at the top under "Search" by design, isn't it? I'd certainly expect it to be.

Amire80 moved this task from Needs Triage to Bugs on the ContentTranslation board.Jun 19 2016, 9:03 PM
Amire80 moved this task from Jan.-Mar. 2017 to CX2 on the ContentTranslation board.May 8 2017, 1:05 PM
santhosh updated the task description. (Show Details)May 10 2017, 4:21 AM

CX2 defines explicit positions of cards in the tools column and prevents this jumping to random position. No plans to fix in CX1

santhosh closed this task as Resolved.May 10 2017, 4:25 AM
santhosh claimed this task.