Page MenuHomePhabricator

Define extension dependencies in maintenance scripts for WMF deployed extensions
Closed, ResolvedPublic

Description

More specifically than T141589, define extension dependancies for WMF deployed extensions that have maintenance scripts

List:

  • AbuseFilter
  • AntiSpoof
  • CentralAuth
  • CentralNotice
  • CheckUser
  • CirrusSearch
  • cldr
  • CodeReview
  • ConfirmEdit
  • ContentTranslation
  • CreditsSource
  • DisableAccount
  • DonationInterface
  • Echo
  • EducationProgram
  • ExtensionDistributor
  • FlaggedRevs
  • Flow
  • GeoData
  • GlobalBlocking
  • GlobalCssJs
  • GlobalUsage
  • GWToolset
  • LocalisationUpdate
  • MassMessage
  • Math
  • MoodBar
  • OATHAuth
  • OAuth
  • OpenStackManager
  • ORES
  • PagedTiffHandler
  • PageImages
  • PageTriage
  • Renameuser
  • SecurePoll
  • SemanticMediaWiki
  • ShortUrl
  • SyntaxHighlight_GeSHi
  • TimedMediaHandler
  • TorBlock
  • Translate
  • TranslationNotifications
  • UniversalLanguageSelector
  • UploadWizard
  • UrlShortener
  • VisualEditor
  • Wikidata
  • wikihiero
  • WikimediaMaintenance

Event Timeline

Reedy created this task.Jul 29 2016, 12:04 AM

TODO: Make a list of affected extensions

Danny_B renamed this task from Define extension dependancies in maintenance scripts for WMF deployed extensions to Define extension dependencies in maintenance scripts for WMF deployed extensions.Jul 29 2016, 12:30 AM

Change 301866 had a related patch set uploaded (by Reedy):
Set extension dependancy in maintenance scripts

https://gerrit.wikimedia.org/r/301866

Reedy added a comment.EditedJul 30 2016, 10:52 AM
reedy@tin:/srv/mediawiki-staging/php-1.28.0-wmf.12/extensions$ grep -R "extends Maintenance" | cut -d'/' -f1 | sort -n | uniq -c
      2 AbuseFilter
      2 AntiSpoof
     14 CentralAuth
      1 CentralNotice
      1 CheckUser
     18 CirrusSearch
      1 cldr
      7 CodeReview
      1 ConfirmEdit
      3 ContentTranslation
      1 CreditsSource
      1 DisableAccount
      5 DonationInterface
      7 Echo
      1 EducationProgram
      1 ExtensionDistributor
     11 FlaggedRevs
     13 Flow
      1 GeoData
      1 GlobalBlocking
      1 GlobalCssJs
      1 GlobalUsage
      1 GWToolset
      1 LocalisationUpdate
      1 MassMessage
      1 Math
      1 MoodBar
      1 OATHAuth
      1 OAuth
      8 OpenStackManager
      3 ORES
      1 PagedTiffHandler
      1 PageImages
      5 PageTriage
      2 Renameuser
      1 SecurePoll
      2 SemanticMediaWiki
      1 ShortUrl
      2 SyntaxHighlight_GeSHi
      4 TimedMediaHandler
      1 TorBlock
     23 Translate
      2 TranslationNotifications
      3 UniversalLanguageSelector
      1 UploadWizard
      1 UrlShortener
      1 VisualEditor
     10 Wikidata
      1 wikihiero
     28 WikimediaMaintenance
Reedy updated the task description. (Show Details)Jul 30 2016, 10:53 AM

Change 301866 merged by jenkins-bot:
Set extension dependency in maintenance scripts

https://gerrit.wikimedia.org/r/301866

Umherirrender added a subscriber: Umherirrender.EditedJan 28 2018, 7:15 PM

You have to grep also for the namespace seperator, because some maintenance scripts are namespaced. And for class LoggedUpdateMaintenance

"extends\s+\\?(?:LoggedUpdate)?Maintenance"

Umherirrender closed this task as Resolved.Jan 30 2018, 8:24 PM
Umherirrender claimed this task.

WikimediaMaintenance left, but there is no explicit load of the extension.json

CirrusSearch, Translate, FlaggedRevs, OpenStackManager, GWToolSet, TimedMediaHandler and Wikibase does not have extension.json yet, could be done when migrated.