Deprecate the reCaptcha module of ConfirmEdit for MediaWiki Release 1.28
Closed, ResolvedPublic

Description

Google at some time announced the following for the old reCaptcha v1 version:

So we decided that it's time to stop supporting the old version of reCAPTCHA, which means:

We won't develop any new features for reCAPTCHA v1.
Any new key registered on reCAPTCHA will be only valid for v2.
If your site still uses reCAPTCHA v1, it will continue to work, but please expect that it may become less functional. We encourage you to register a new key and upgrade to v2 soon.

Source: https://developers.google.com/recaptcha/docs/faq

ConfirmEdit still supports the old reCaptcha version, but it seems to doesn't make sense anymore, as Google will not support the version in the near future (I suppose). So we should find a way of either:

  • Depreacte the old reCaptcha in Version 1.28 of MediaWiki and remove it in the upcoming 1.29 release
  • Deprecate the old reCaptcha in the upcoming Version 1.29 or MediaWiki and remove it:
    • in MediaWiki 1.30
    • When Google doesn't support the old reCaptcha anymore

I'll send a notification about this task to wikitech-l and probably some other lists (where mostly third-party users should be subscribed to, as they're the only ones using this module) asking for opinions. If no-one seems to be interested in writing something, I'll choose one way and upload a change for it :P

Florian created this task.Aug 4 2016, 8:31 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 4 2016, 8:31 PM
Samtar added a subscriber: Samtar.Aug 5 2016, 1:53 PM
Subfader added a subscriber: Subfader.EditedAug 5 2016, 9:38 PM

Feedback: In ConfirmEdit I only use $wgCaptchaQuestions > for registration which gives edit rights. Works rock solid for me and I hope it will be supported in the future.

Paladox renamed this task from Deprecate the reCaptcha module of ConfirmEdit for MediaWiki Release 1.27 or 1.28 to Deprecate the reCaptcha module of ConfirmEdit for MediaWiki Release 1.28.Aug 28 2016, 9:00 PM
Paladox updated the task description. (Show Details)
Paladox added a subscriber: Paladox.

So...the release is in a week, what's the plan?

Florian triaged this task as Normal priority.Nov 18 2016, 5:33 PM

Because there's no real objection here for some time, I'll propose a patch, which deprecates the use of the old reCaptcha v1, which means, that we select option a:

Depreacte the old reCaptcha in Version 1.28 of MediaWiki and remove it in the upcoming 1.29 release

Change 322292 had a related patch set uploaded (by Florianschmidtwelzow):
Mark ReCaptcha as deprecated

https://gerrit.wikimedia.org/r/322292

Change 322292 merged by jenkins-bot:
Mark ReCaptcha as deprecated

https://gerrit.wikimedia.org/r/322292

Change 322315 had a related patch set uploaded (by Legoktm):
Mark ReCaptcha as deprecated

https://gerrit.wikimedia.org/r/322315

Change 322315 merged by jenkins-bot:
Mark ReCaptcha as deprecated

https://gerrit.wikimedia.org/r/322315

I'll propose a patch, which deprecates the use of the old reCaptcha v1

@Florian: Patch merged - anything left to do here?

Florian closed this task as Resolved.Dec 21 2016, 8:06 AM

Oh, äh, no :P Sorry, missed that the task is still open! :)