Page MenuHomePhabricator

Dashboard: Mobile App Events needs fixing
Closed, ResolvedPublic1 Story Points

Description

Looking at the dashboard for app events - we have a serious and large decrease in events starting around July 28, 2016 (for android) as evidenced by this image (below) and this check-in. This appears to have been an update done to the schema but we didn't know about it.

For iOS, it appears that a drop in those events occurred earlier (around March 9, 2016) and have steadily decreased since then.

We'll need to figure these things out and get them fixed.

Details

Related Gerrit Patches:
wikimedia/discovery/golden : masterCombine MobileWikiAppSearch revisions

Event Timeline

debt created this task.Aug 19 2016, 7:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 19 2016, 7:58 PM
debt triaged this task as Unbreak Now! priority.Aug 19 2016, 7:59 PM
Restricted Application added subscribers: Luke081515, TerraCodes. · View Herald TranscriptAug 19 2016, 7:59 PM

Specifically, the iOS app uses schema revision #10641988 (see this) but the Android app now uses schema revision #15729321 (see this) and our data collection script only reads events from MobileWikiAppSearch_10641988, which is now only receiving events from iOS app and pre-June 28th Android app.

^ @chelsyx btw in the future this is how we'd figure out this problem

Dbrant added a subscriber: Dbrant.Aug 19 2016, 8:14 PM

Yep, I can confirm that the current production Android app is using revision #15729321. Apologies for not giving a heads-up when it was updated.

JMinor added a subscriber: JMinor.Aug 19 2016, 8:17 PM

The initial iOS drop in March was due to the 5.0.0 release and the switch from "opt-out" to "opt-in" event tracking for users.

Yep, I can confirm that the current production Android app is using revision #15729321. Apologies for not giving a heads-up when it was updated.

No harm no foul! :) We should be able to backfill because it's within the 90 day window.

Do you know of any methods you can recommend for watching particular files in git repos? Like if I wanted to subscribe to changes to SearchFunnel.java and WMFSearchFunnel.m to get notified of revision # updates?

Change 305736 had a related patch set uploaded (by Bearloga):
Combine MobileWikiAppSearch revisions

https://gerrit.wikimedia.org/r/305736

Change 305736 merged by Chelsyx:
Combine MobileWikiAppSearch revisions

https://gerrit.wikimedia.org/r/305736

debt added a comment.Aug 22 2016, 9:33 PM

Hi @mpopov and @chelsyx - please be sure to add a note for the reason for the iOS drop in events on this dashboard page.

thanks!

@debt: Will try to backfill since the affected date range is within the 90 day window. If for some reason we can't, will note the drop for Android.

For iOS, will just note that the iOS app has an opt-out feature which might partially explain that drop.

debt added a comment.Aug 23 2016, 11:20 PM

Cool, thanks @mpopov !

mpopov set the point value for this task to 1.Aug 23 2016, 11:40 PM
debt closed this task as Resolved.Aug 26 2016, 4:15 PM

woohoo!