Page MenuHomePhabricator

Install PHP5.5 on jessie CI instances
Closed, DeclinedPublic

Description

The repository we added for PHP 7 (T144872) also has PHP 5.5 packages, so we can install those on jessie.

I think we'd still want to have some jobs run on trusty though because that has 5.5.9, which is the minimum supported version.

Event Timeline

Legoktm created this task.Sep 7 2016, 5:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 7 2016, 5:12 PM
Legoktm triaged this task as Low priority.Sep 7 2016, 5:12 PM
Paladox added a subscriber: Paladox.Sep 7 2016, 5:12 PM
Paladox removed a subscriber: Paladox.Oct 14 2016, 9:56 AM
Paladox added a subscriber: Paladox.
hashar closed this task as Declined.Nov 18 2016, 3:00 PM
hashar added a subscriber: hashar.

I dont think we need Zend 5.5 on Jessie images that is available on Trusty images for now. When we phase out Trusty, we can reconsider and add Zend 5.5 on Jessie images.

Legoktm reopened this task as Open.Dec 8 2016, 8:39 PM
Legoktm lowered the priority of this task from Low to Lowest.

Re-opening and setting as lowest priority so I don't forget about this. The main purpose of this was to be able to run 5.5, 5.6, and 7.0 tests in the same job.

hashar added a comment.Dec 8 2016, 8:49 PM

Ah that makes sense. Does sury provides a 5.5 package that would be coinstallable with their 7.0 one?

yes sury has 5.5 packages that co-install. Currently there are co-installable packages for 5.5, 5.6, 7.0 and 7.1

hashar added a comment.EditedDec 8 2016, 10:14 PM

So in Production we get the Zend packages from the distributions via the puppet class modules/mediawiki/manifests/packages/php5.pp which are:

TrustyZend 5.5
JessieZend 5.6

For contint we use a different class modules/contint/manifests/packages/php.pp though similar. Which ships some additional packages compared to the production class (eg for stuff we dont use in production such as php5-sqlite). AND we get the sury packages:

JessieZend 7.0 (sury)

Guess in the os_version('debian == jessie') conditional, we will want to add the php5.5-* packages we need.

hashar closed this task as Declined.Apr 3 2017, 2:39 PM

Unsurprisingly sury.org no more provides PHP 5.5 packages since it has reached end of life. https://www.patreon.com/posts/php-5-5-end-of-7174814

http://packages.dotdeb.org has php5.5 packages. We should try to run multi php on jessie. Will allow more jessie tests to run.