Page MenuHomePhabricator

Entered project tag lost after creating task when turning browser JS off mid-session
Closed, DeclinedPublic

Description

There is a bug in Phabricator.

Safari Mac.
In Phabricator, I am creating a new task...
In the field Tags, I write phabricator
I send the new task.

Expected result:

The new task has the tag Phabricator.

Observed result:

The new task has no tag. The entered tag has been lost.

Event Timeline

Nnemo created this task.Oct 2 2016, 8:34 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 2 2016, 8:34 AM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptOct 2 2016, 8:35 AM
Nnemo awarded a token.Oct 2 2016, 8:35 AM

Cannot reproduce... Unfortunately this report lacks some information. If you have time and can still reproduce the problem, please add a more complete description to this report - browser information, browser settings (for example if JavaScript is disabled) etc. are welcome.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

Aklapper renamed this task from The entered tag is lost to Entered project tag lost after creating task.Oct 2 2016, 8:55 AM
Aklapper removed a project: Accessibility.
Aklapper updated the task description. (Show Details)
Nnemo added a comment.Oct 2 2016, 9:45 AM

@Aklapper

Thank you.

Actually, my case was a little special: I had Saf Mac with JavaScript on, I had the form, and later I turned off JavaScript, and later I wrote "phabricator" in the field "Tags". The text "phabricator" appeared in the field. So I expected Phab to keep the tag. Is this case valid? I am inclined to say yes.

And now comes of another case: I have Saf Mac with JS on, I load the form, I enter my things..., in the field "Tags" I write "phabricator", and I click the button "Create new task". This case triggers the bug too.

Do you just write phabricator in, or do you select it from the type-a-head and select it (so it turns into the visual representation of the tag?

greg added a subscriber: greg.Oct 4 2016, 3:34 PM

Actually, my case was a little special: I had Saf Mac with JavaScript on, I had the form, and later I turned off JavaScript, and later I wrote "phabricator" in the field "Tags". The text "phabricator" appeared in the field. So I expected Phab to keep the tag. Is this case valid? I am inclined to say yes.

Why? Why should a web app be OK with you loading a page with JS on, then turning it off and expecting everything to just work? Messing with your JS settings mid-session isn't really a normal user thing and not something that should be expected to "just work" in all cases.

Proposing invalid.

Aklapper closed this task as Invalid.Oct 7 2016, 5:16 PM

Indeed. Closing as invalid as per last comment.

Nnemo added a comment.Oct 22 2016, 9:06 PM

It would be nice to correct this bug.

Thank you.

@Nnemo: This 'bug' will not get corrected as the behavior is not considered a software bug, due to the 'unusual' steps performed by the task reporter. Hence this task was closed as invalid (instead of declined). Sorry. :)

Do you just write phabricator in, or do you select it from the type-a-head and select it (so it turns into the visual representation of the tag?

I just wrote "phabricator" in the field.

@Aklapper

Actually, my case was a little special: I had Saf Mac with JavaScript on, I had the form, and later I turned off JavaScript, and later I wrote "phabricator" in the field "Tags". The text "phabricator" appeared in the field. So I expected Phab to keep the tag. Is this case valid? I am inclined to say yes.

Why? Why should a web app be OK with you loading a page with JS on, then turning it off and expecting everything to just work?

Because I have high expectations. :-) A Web page is supposed to work without JS. When I turn off JS, I agree if some fancy effects or some user-friendly helps stop working, but the essential stuff is expected to still work, and certainly not to silently lose data.

Good Web apps with JavaScript work in a graceful manner when JavaScript is not available. [Generally, MediaWiki works so, for example.]

@Nnemo: This 'bug' will not get corrected as the behavior is not considered a software bug, due to the 'unusual' steps performed by the task reporter. Hence this task was closed as invalid (instead of declined). Sorry. :)

The first use case is a little special, but I still think it is a valid use case that triggers a bug.

The second use case is perfectly valid and triggers a bug. Otherwise, why would not it be valid? It has JS on, and no JS switching.

Nnemo reopened this task as Open.Oct 23 2016, 12:11 AM
Peachey88 closed this task as Invalid.Oct 23 2016, 12:19 AM

Because I have high expectations. :-) A Web page is supposed to work without JS. When I turn off JS, I agree if some fancy effects or some user-friendly helps stop working, but the essential stuff is expected to still work, and certainly not to silently lose data.

There is a huge difference between loading a webpage with (or without) JavaScript and utilizing it, Compared to loading it with Javascript then turning it off in your browser and magically expecting stuff to work when it expects JS to be turned on.

Resolving this is Invalid again.

If you truly believe the upstream Phabricator package should support the usage of altering javascript usage by disabling it after a page has been loaded with it turned on, you can find the tracker at https://secure.phabricator.com as we won't be patching for that use case (which to my knowledge no one else, who uses our phabricator instance does or has tried)

I think that our goal here is to improve the software and processes, not to close the tasks.

Because I have high expectations. :-) A Web page is supposed to work without JS. When I turn off JS, I agree if some fancy effects or some user-friendly helps stop working, but the essential stuff is expected to still work, and certainly not to silently lose data.

There is a huge difference between loading a webpage with (or without) JavaScript and utilizing it, Compared to loading it with Javascript then turning it off in your browser and magically expecting stuff to work when it expects JS to be turned on.

The page expects JS to be turned on? It did not say so. The user does not know about that. When I turned off JS, I was probably in another window, and, when I went back to the Phab tab, the page had not changed. I was not supposed to know that this page needs JS.

Besides, "magic" exists: it is a good design practice: a Web app can be designed to work gracefully, maybe in a degraded mode, when JS does not work.

Resolving this is Invalid again.

If you truly believe the upstream Phabricator package should support the usage of altering javascript usage by disabling it after a page has been loaded with it turned on, you can find the tracker at https://secure.phabricator.com as we won't be patching for that use case (which to my knowledge no one else, who uses our phabricator instance does or has tried)

Can you answer about the second use case? It has no disabling JS.

If some people estimate that we don't want a correction of this bug, then this would not be nice, but I would accept that. In this case, this task would have to be "declined", not "invalid".

But I think that it is more constructive to try to improve the things than to try to close proposals of improvement.

Nnemo reopened this task as Open.Oct 23 2016, 12:48 AM
Nnemo added a comment.Oct 23 2016, 1:16 AM

Messing with your JS settings mid-session isn't really a normal user thing

Why? I think that switching JS in a navigator having page(s) loaded is a normal thing. As a user, I switch JS easily in my navigator, in a menu. In another navigator, I have a simple button for switching JS. When I switch JS off or on, I get no warning, and the loaded pages remain.

Aklapper closed this task as Declined.Oct 23 2016, 12:32 PM

(I do not know which "second usecase" is being referred to.)

I think that our goal here is to improve the software and processes, not to close the tasks.

Our goal is to spend efforts improving the software when it's reasonable. That is not the case for the corner case described in this task (changing cardinal browser settings while interacting with a web site and expecting the website to behave like before the change).

Hence I am closing this task as declined, as no-one will work on fixing the described behavior.

greg renamed this task from Entered project tag lost after creating task to Entered project tag lost after creating task when turning browser JS off mid-session.Oct 24 2016, 5:55 PM