Page MenuHomePhabricator

No Tickets tab in Italian interface
Closed, ResolvedPublic

Description

Usually, on the top left of the "home page" of the OTRS system, called Dashboard in English, there are two tabs: Tickets and Dashboard. In the Italian OTRS "home page", these two tabs aren't there, while I would expect to have access to the Tickets and the queues from the Dashboard.

To reproduce the issue: 1) click the "Edit personal preferences" top left wheel, 2) in the Language area, select Italiano-Italian, 3) click Update, 4) click on Cruscotto (top left).
You should now see a Dashboard, with no access to the Tickets tab.

NB: The Tickets tab appears regularly when you are inside a ticket.

Related Objects

Event Timeline

Ruthven created this task.Oct 4 2016, 5:05 PM
Ruthven updated the task description. (Show Details)Oct 4 2016, 9:53 PM
pajz added subscribers: akosiaris, pajz.

This appears to be a known issue caused by the Online Agent widget (upstream bug report: http://bugs.otrs.org/show_bug.cgi?id=11878). According to the change notes, it's been fixed ever since OTRS 5.0.8 (our current version: 5.0.7; current stable version: 5.0.13). @akosiaris, do you know if there any plans to apply the latest of those patch-level updates? There are also one or two other bug reports here that likewise have seen upstream fixes since they were reported.

In the meantime, you can, as a work-around, disable the Online Agent widget on the Dashboard ("In linea"). At least in my case, this has indeed immediately brought back the menu bar.

Removing the Online Agent widget solves the issue right away for me as well. It's a nice workaround. Thank you.

This appears to be a known issue caused by the Online Agent widget (upstream bug report: http://bugs.otrs.org/show_bug.cgi?id=11878). According to the change notes, it's been fixed ever since OTRS 5.0.8 (our current version: 5.0.7; current stable version: 5.0.13). @akosiaris, do you know if there any plans to apply the latest of those patch-level updates? There are also one or two other bug reports here that likewise have seen upstream fixes since they were reported.

Yes, let's carve out a plan for applying those patch level updates. There have been enough bugs fixed that it warrants an update. I 'll schedule an upgrade on Tuesday Oct 11, 09 UTC

akosiaris moved this task from Incoming to Backlog on the OTRS board.

The upgrade has been done. @Ruthven has the issue been resolved (without using the workaround) ?

@akosiaris The problem is still there after the upgrade.

pajz added a comment.Nov 22 2016, 3:25 PM

I can also still reproduce the issue; per https://bugs.otrs.org/show_bug.cgi?id=11878#c8, it seems to be an issue on our end, however. Quoting from there,

Can you please check, if you have a manually chenged template file for the widget (AgentDashboardUserOnline.tt) which still contains the unfixed code?

@akosiaris, could you check that? Perhaps this could be due to the fact that, if I'm not mistaken, we're modifying the Online user widget through our customized Wikimedia... package, so perhaps the old code is still contained there somehow?

I can also still reproduce the issue; per https://bugs.otrs.org/show_bug.cgi?id=11878#c8, it seems to be an issue on our end, however. Quoting from there,

Can you please check, if you have a manually chenged template file for the widget (AgentDashboardUserOnline.tt) which still contains the unfixed code?

@akosiaris, could you check that? Perhaps this could be due to the fact that, if I'm not mistaken, we're modifying the Online user widget through our customized Wikimedia... package, so perhaps the old code is still contained there somehow?

Of course we do that. It's in https://phabricator.wikimedia.org/diffusion/OSOT/browse/master/packages/WikimediaTemplates/Custom/Kernel/Output/HTML/Templates/Standard/

The reasons for this WMF package are in https://phabricator.wikimedia.org/diffusion/OSOT/browse/master/packages/WikimediaTemplates/WikimediaTemplates.sopm

So our package needs an update as it seems. Hopefully it will be easy. I 'll try and update it.

Change 322916 had a related patch set uploaded (by Alexandros Kosiaris):
Update Templates for 5.0.13 version

https://gerrit.wikimedia.org/r/322916

Change 322916 merged by Alexandros Kosiaris:
Update Templates for 5.0.13 version

https://gerrit.wikimedia.org/r/322916

Package updated with 5.0.13 changes, built and installed. @Ruthven could you please give it another shot? If the OTRS devs were correct, it should be fixed now

pajz added a comment.Dec 1 2016, 6:38 AM

Can confirm that I can no longer reproduce the issue.

akosiaris closed this task as Resolved.Dec 1 2016, 10:12 AM
akosiaris claimed this task.

Resolving then. Thanks!