Page MenuHomePhabricator

Move a Flow board is not possible
Closed, ResolvedPublic

Description

I had a request to move a Flow board on ar.wp, from أسئلة to أسئلة عامة on ويكيبيديا namespace.

1/ I just move the page and I had the following message:

  • You do not have permission to move this page, for the following reasons:
  • A page of that name already exists, or the name you have chosen is not valid. Please choose another name.
  • "flow-board" content is not allowed on page ويكيبيديا:أسئلة عامة
  • Page already exists at destination, so a Flow board can not be moved there.

2/ I've asked a sysop to delete the page and then tried to do the change again. I get the same message.

3/ I've created a Flow board at the destination and then tried to do the change again. I get the same message.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptOct 12 2016, 5:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

The destination should be completely non-existent before you do the move. Please have the blank destination deleted again, then post the error messages after that.

(Shouldn't matter much, but FYI that is NS_PROJECT.)

Checked in betalabs (in production it might work differently) - it seems that I cannot move Flow enabled pages at all.

  1. The destination page does not exist. As a user I have all rights to move/enable Flow on any pages.

Moving Flow enabled page will give

"flow-board" content is not allowed on [destination page title]
  1. The destination page does exist (and not empty) and it's a Flow enabled page.
  • Moving Flow enabled page will give the whole error message
The page could not be moved: a page of that name already exists, or the name you have chosen is not valid.

Please choose another name, or use Requested moves to ask an administrator to help you with the move.

Do not manually move the article by copying and pasting it; the page history must be moved along with the article text.
"flow-board" content is not allowed on page Talk:ET1
Page already exists at destination, so a Flow board can not be moved there.
  • after the destination Flow enabled page was deleted, the the error message will say:
"flow-board" content is not allowed on [destination page title]
  1. Created empty Flow enabled Talk page and tried to move another Flow enabled Talk page to it.

The whole error message is displayed:

The page could not be moved: a page of that name already exists, or the name you have chosen is not valid.

Please choose another name, or use Requested moves to ask an administrator to help you with the move.

Do not manually move the article by copying and pasting it; the page history must be moved along with the article text.
"flow-board" content is not allowed on page Talk:ET1
Page already exists at destination, so a Flow board can not be moved there.

Deleting the destination page (empty Flow enabled page) and attempting to move brings the familiar message:

"flow-board" content is not allowed on [destination page title]

@Etonkovidova What is the URL and username?

@Mattflaschen-WMF
On en.wikipedia.beta.wmflabs.org/wiki/

Username: Etonkovidova
Tried to move pages: Talk:ET16 and Talk:ET17 which I ended up deleting them.

The same behavior was for the userET100 (Autoocnfirmed user group) which should be able to move pages but without Flow enabled rights.

Moving wikitext pages is fine.

I deleted the target page again, so you can anytime move the page.

Mattflaschen-WMF added a comment.EditedOct 14 2016, 3:23 AM

I tried to test this on Beta, but ran into serious unrelated problems (T148111: DBQueryError when creating account on Beta, or logging into newly-created accounts which I can't track down due to T146723: deployment-fluorine02 does not have logs).

Mattflaschen-WMF added a comment.EditedOct 14 2016, 3:26 AM

However, that account should indeed be able to move boards (regardless of destination, as long as destination is completely non-existent), so I can test it with https://wikitech.wikimedia.org/wiki/Debugging_in_production#Debugging_action_API_requests_in_shell .

Trizek-WMF added a comment.EditedOct 14 2016, 4:36 PM

Thanks @Ibrahim.ID!

The destination should be completely non-existent before you do the move. Please have the blank destination deleted again, then post the error messages after that.
(Shouldn't matter much, but FYI that is NS_PROJECT.)

You do not have permission to move this page, for the following reason:
"flow-board" content is not allowed on page ويكيبيديا:أسئلة عامة

Moving Flow enabled page will give

"flow-board" content is not allowed on [destination page title]

Confirmed on Beta and locally.

Change 316037 had a related patch set uploaded (by Mattflaschen):
Fix page moves by calling safeAllowCreation in canBeUsedOn

https://gerrit.wikimedia.org/r/316037

Change 316037 merged by jenkins-bot:
Fix page moves by calling safeAllowCreation in canBeUsedOn

https://gerrit.wikimedia.org/r/316037

Etonkovidova added a comment.EditedOct 25 2016, 8:51 PM

Checked in betalabs - the test cases are in the table below

(1) User with Flow bots rights moving Flow board

Test descriptionResult
Moving to non-existent page in Talk namespaceOk
Moving to non-existent page in Article namespaceOk
Moving to existing pages in Article/Talk namespacesuser warning
Moving to previously deleted Flow boardOK
Moving to previously wikitext pageOk

(2) User without Flow bots rights cannot move Flow board although 'Move' option is present.
I tried it in betalabs with the user ET58 who belongs to
Member of groups:Edit filter managers, Autoconfirmed users, Autopatrolled, Confirmed users, Course campus volunteers, Course coordinators, Course instructors, Course online volunteers, File movers, Mass message senders, Reviewers, Template editors, Users

The warning message does not relay correct info to a user

"flow-board" content is not allowed on page [destination page title]

Should the option 'Move be removed or the warning message be corrected?
T149119: Better user experience for users without the right to move Flow boards

I'm drafting the Collaboration newsletter. What's new about that task? Can we announce something?

I'm drafting the Collaboration newsletter. What's new about that task? Can we announce something?

This is fixed as far as I can tell. @Etonkovidova filed a followup, T149119: Better user experience for users without the right to move Flow boards , about UX issue (which I think is pre-existing).

Etonkovidova added a comment.EditedNov 5 2016, 12:27 AM

Re-checked on testwiki with 1.29.0-wmf as a user with 'Flow bot' rights. Also checked the case when moving Flow board from Talk namespace to Wikipedia namespace (the issue was filed about this particular move). All moves seem to be working as expected.

Trizek-WMF closed this task as Resolved.Nov 7 2016, 11:19 AM

I've managed to move the board. :)

Resolving, feel free to reopen if needed.