Page MenuHomePhabricator

Score extension no longer features TMH player for generated <audio> elements
Closed, ResolvedPublic

Description

Probably when we fixed TMH with proper module loading, we forgot about this dependency and no one has noticed (for like a year ???).

See also: https://en.wikipedia.org/wiki/Help:Score#MIDI_instruments

Event Timeline

TheDJ created this task.Oct 20 2016, 10:27 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 20 2016, 10:27 AM
Ebe123 added a subscriber: Ebe123.Dec 17 2017, 9:34 PM

The non-TMH player is nicer and just as functional in this case IMO.

Ebe123 raised the priority of this task from Low to High.Jan 1 2018, 12:36 AM

Audio not in TimedMediaHandler's format cannot be played in the Safari browser (using Version 11.0.2 (13604.4.7.1.3)). Seems more serious as a bug now, and TMH should formalize how to instantiate players for other extensions.

brion added a comment.Jan 8 2018, 8:56 PM

Yeah, looks like it triggers if there's also a TMH file usage on the page, but not if there isn't. Will take a peek at this, though T181875 would also solve the Safari problem.

Change 402935 had a related patch set uploaded (by Brion VIBBER; owner: Brion VIBBER):
[mediawiki/extensions/Score@master] Regression fix for TMH Score integration

https://gerrit.wikimedia.org/r/402935

Change 402935 merged by jenkins-bot:
[mediawiki/extensions/Score@master] Regression fix for TMH Score integration

https://gerrit.wikimedia.org/r/402935

Ebe123 closed this task as Resolved.Feb 7 2018, 6:15 AM
Ebe123 assigned this task to brion.

Guess we can close this now!